1 # Maintainer : Christian Rebischke <Chris.Rebischke@archlinux.org>
2 # Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
3 # Contributor: Anatol Pomozov <anatol.pomozov gmail>
4 # Contributor: RunningDroid <runningdroid AT zoho.com>
5 # Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
10 pkgdesc='C++ Library for commandline flag processing'
12 url='https://github.com/schuhschuh/gflags'
16 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/schuhschuh/gflags/archive/v${pkgver}.tar.gz")
17 sha512sums=('98c4703aab24e81fe551f7831ab797fb73d0f7dfc516addb34b9ff6d0914e5fd398207889b1ae555bac039537b1d4677067dae403b64903577078d99c1bdb447')
18 options=('!lto' 'staticlibs')
23 -DCMAKE_INSTALL_PREFIX=/usr \
24 -DCMAKE_BUILD_TYPE=Release \
25 -DREGISTER_INSTALL_PREFIX=OFF \
26 -DBUILD_SHARED_LIBS=ON \
27 -DBUILD_STATIC_LIBS=ON \
39 make DESTDIR="${pkgdir}" install
40 install -D -m644 COPYING.txt "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING.txt