upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-ansi-wl-pprint / trunk / PKGBUILD
blob9fe99977caf4b2cc032743f09cedfa21d8ea9151
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=ansi-wl-pprint
5 pkgname=haskell-ansi-wl-pprint
6 pkgver=0.6.9
7 pkgrel=374
8 pkgdesc="The Wadler/Leijen Pretty Printer for colored ANSI terminal output"
9 url="https://github.com/ekmett/ansi-wl-pprint"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-ansi-terminal')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('2a66236f740f0b45b6133555e8b1315dc85ece1c16dd51e4aa7f31d2fee03d66869af5f81e6383aa840f503c2cad46f3655f53b784ebca7b3480efb53eea2a04')
17 prepare() {
18     cd $_hkgname-$pkgver
19     sed -i 's/< *0.10/<1/' $_hkgname.cabal
22 build() {
23     cd $_hkgname-$pkgver
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28             -f-example
29     runhaskell Setup build $MAKEFLAGS
30     runhaskell Setup register --gen-script
31     runhaskell Setup unregister --gen-script
32     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 package() {
37     cd $_hkgname-$pkgver
39     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
40     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
41     runhaskell Setup copy --destdir="$pkgdir"
42     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
43     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE