1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 _hkgname=timezone-series
4 pkgname=haskell-${_hkgname}
7 pkgdesc='Enhanced timezone handling for Data.Time'
8 url='http://projects.haskell.org/time-ng/'
13 source=(https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha256sums=('28efb715e3b7c25cbc13c468ab847d3a7b7bca0f5787b56bc1da53dee5e1c6a2')
15 sha512sums=('7e98bf1030f9df88d031f8fe28e56f50bd8e5da7615165324b5132a77aecc70da5906e2068afa43a819d711725c4c6cae8f6d17e7803f50b31038eb1634d4992')
18 cd ${_hkgname}-${pkgver}
19 runhaskell Setup configure -O \
21 --enable-executable-dynamic \
22 --disable-library-vanilla \
24 --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
25 --dynlibdir=/usr/lib \
26 --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
29 runhaskell Setup build $MAKEFLAGS
30 runhaskell Setup haddock
31 runhaskell Setup register --gen-script
32 runhaskell Setup unregister --gen-script
33 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 cd ${_hkgname}-${pkgver}
39 runhaskell Setup test --show-details=direct
43 cd ${_hkgname}-${pkgver}
44 install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
45 install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
46 install -dm 755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
47 runhaskell Setup copy --destdir="$pkgdir"
49 install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
50 ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"