upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / lib32-libaio / trunk / PKGBUILD
blob098fafc946c7c4cc10a18d96c0b2150930bdb59e
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 # Contributor: josephgbr <rafael.f.f1@gmail.com>
4 # Contributor: angvp <angvp@archlinux.org>
6 _name=libaio
7 pkgname=lib32-libaio
8 pkgver=0.3.113
9 pkgrel=2
10 pkgdesc='The Linux-native asynchronous I/O facility (aio) library'
11 arch=(x86_64)
12 url="https://pagure.io/libaio"
13 license=(LGPL2.1)
14 depends=(
15   lib32-glibc
16   $_name=$pkgver
18 provides=(libaio.so)
19 source=(https://pagure.io/libaio/archive/$_name-$pkgver/$_name-$_name-$pkgver.tar.gz)
20 sha512sums=('8058c927de0b5f7079fc232d2be23272537694bf271488af1dc0330b58afc307931792ab138512c5e00aa3ea921935a6d862f575fb0cc2bf323de63d8df208cd')
21 b2sums=('e06c1c1cc118c15f6bed1abfa97368d7ccc0d2e716a233cd4141936fb382e40909c340a6c882b18ee9461aaa23dd77a6644a38bdb5a00c1444538a2e0ab816d4')
23 prepare() {
24   # -Werror, not even once
25   sed 's/-Werror//' -i $_name-$_name-$pkgver/harness/Makefile
27   # disable failing test until upstream fixes it: https://pagure.io/libaio/issue/21
28   rm -rf $_name-$_name-$pkgver/harness/cases/23.t
31 build() {
32   export CC='gcc -m32'
33   export CXX='g++ -m32'
34   export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
35   # AIO library is a thin wrapper around kernel syscalls, it does not use stdlib
36   # and other helpers like stack protection libraries
37   export CFLAGS='-march=x86-64 -mtune=generic -O2 -pipe'
39   make -C $_name-$_name-$pkgver
42 check() {
43   make partcheck -k -C $_name-$_name-$pkgver
46 package() {
47   make DESTDIR="$pkgdir" libdir=/usr/lib32 install -C $_name-$_name-$pkgver
48   rm -rf "$pkgdir"/usr/include
51 # vim: ts=2 sw=2 et: