upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-handy-archives / repos / community-any / PKGBUILD
blobb7cb9f59cfe7985ee62bce8cbdc9e68d5c1118c6
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=python-handy-archives
4 pkgver=0.1.4
5 pkgrel=2
6 pkgdesc='Handy archive helpers for Python'
7 arch=('any')
8 url='https://handy-archives.readthedocs.io/'
9 license=('MIT')
10 depends=('python')
11 makedepends=(
12   'git'
13   'python-build'
14   'python-installer'
15   'python-flit-core'
17 #checkdepends=('') pytest+coincidence
18 #optdepends=('')
19 _commit='2727131dde46ecf1aa9cc39362e8a8255a9ccaf5'
20 source=("$pkgname::git+https://github.com/domdfcoding/handy-archives#commit=$_commit")
21 b2sums=('SKIP')
23 pkgver() {
24   cd "$pkgname"
26   git describe --tags | sed 's/^v//'
29 build() {
30   cd "$pkgname"
32   python -m build --wheel --no-isolation
35 package() {
36   cd "$pkgname"
38   python -m installer --destdir="$pkgdir" dist/*.whl
40   # license
41   install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE