1 # Maintainer: Bruno Pagani <archange@archlinux.org>
7 pkgdesc="Ultra fast cross-platform multiple screenshots module"
9 url="https://github.com/BoboTiG/python-mss"
12 makedepends=(python-build python-installer python-setuptools)
13 checkdepends=(python-pytest xorg-server-xvfb libxrandr lsof python-flaky python-wheel)
14 source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
15 #source=(${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
16 sha256sums=('f14cee528903c3b01d3b8f1209cd498422f71e3d0d2d92c5b933edd3b9772022')
20 python -m build --wheel --no-isolation
25 PYTHONPATH="${PWD}/build/lib/" xvfb-run -a -s "+extension RANDR +render -screen 0 1024x768x24" pytest -k 'not test_wheel_python_3_only'
30 python -m installer --destdir="${pkgdir}" dist/*.whl
31 install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}