1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-pytest-mock
5 _commit=6c03dfd4240de4a178bab67c0a32fba28d8bcf91
7 pkgdesc="Thin-wrapper around the mock package for easier use with py.test"
10 url="https://github.com/pytest-dev/pytest-mock/"
11 depends=('python-pytest')
12 makedepends=('git' 'python-setuptools-scm')
13 checkdepends=('python-pytest-asyncio')
14 source=("git+https://github.com/pytest-dev/pytest-mock.git#commit=$_commit")
24 python setup.py egg_info
25 export PYTHONPATH="src:${PYTHONPATH}"
26 # disable all tests that require the plugin to be installed
27 pytest -v --assert=plain \
28 -k "not test_used_with_session_scope \
29 and not test_used_with_package_scope \
30 and not test_used_with_module_scope \
31 and not test_used_with_class_scope \
32 and not test_monkeypatch_ini \
33 and not test_monkeypatch_native \
34 and not test_standalone_mock \
35 and not test_plain_stopall"
40 python setup.py install --root="$pkgdir" --optimize=1