1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Cravix <dr.neemous@gmail.com>
3 # Contributor: AlexanderR <rvacheva@nxt.ru>
4 # Contributor: zhn <zhangn1985@gmail.com>
13 pkgdesc="The Ren'Py Visual Novel Engine"
15 url=https://www.renpy.org
30 python-sphinx-bootstrap-theme
33 'code: Default editor'
36 _tag=23e313d5e0376c9a1b13ae6beb7861368f8acc5b
38 git+https://github.com/renpy/renpy.git#tag=${_tag}
42 renpy-system-fribidi.patch
47 'bbf0d25ad1671f7046cced56024a9c023533a1c28e9cff62e77203bbecae220d35cbe00a896483324ee3b778a1335c1d156894d6f2b692b4960a5bf48bf5d502'
48 'b5bec9d19a25ae849d0e86e483040b320be9048b55ba002cc83d4ee018e99ff7549ba26a60afe6522c2efe2abb724f2679750e25f8d7c161847ad1babeccf006'
49 'd0b22e3f970f28096a6ea50019d708a568cfca489acc3c5b1bbce78a0b5afc35d43712b5348ab88b643543ce4f627c31a83eacaab293bede55de2eeabfea2238'
50 '1e1c8b1a8d670c7ec1587b13140972d463ba6a442f895e73ba9df45f36c52babe86783180b0d265e4bb93df44ad31ed5c0e9e859d656d253ad086b8fdb784281'
51 '12c237ed94d210fee5de799be2c827d38aa994b2727299e1c8a4e8d4e9e60141ff4cc5764ebf070ec3cf50640fe4b851eab95819a401c7880037bc4483815d30'
52 '0d5258d59d9bbcd4122b2ffda82b088838b134c250edb0a3e95f727a3bd0c0263d3942d4e27877d192fb14433fce0f8d99aa20e9efcb7df86c884418ba6e1b80')
56 git cherry-pick -n 909e61decbc2d9c63a5c05f0a27a849f4ab205fc
57 patch -Np1 -i ../renpy-system-fribidi.patch
58 patch -Np1 -i ../renpy-version.patch
63 python module/setup.py build
64 python -m compileall renpy
65 local python_version=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
66 PYTHONPATH=module/build/lib.linux-x86_64-cpython-${python_version} python renpy.py . compile
67 PYTHONPATH=module/build/lib.linux-x86_64-cpython-${python_version} python renpy.py the_question compile
68 PYTHONPATH=module/build/lib.linux-x86_64-cpython-${python_version} python renpy.py tutorial compile
70 PYTHONPATH=../module/build/lib.linux-x86_64-cpython-${python_version} ./build.sh
75 'renpy-demos: Tutorial and The Question demos'
76 'tk: Set projects directory'
80 python module/setup.py install --root="${pkgdir}" --optimize=1 --skip-build
81 install -dm 755 "${pkgdir}"/usr/share/{renpy,doc}
82 cp -dr --no-preserve=ownership doc gui launcher renpy renpy.py sdk-fonts "${pkgdir}"/usr/share/renpy/
83 ln -s /usr/share/renpy/doc "${pkgdir}"/usr/share/doc/renpy
84 install -Dm 755 ../renpy.bin "${pkgdir}"/usr/bin/renpy
85 install -Dm 644 ../renpy.desktop -t "${pkgdir}"/usr/share/applications/
86 install -Dm 644 ../renpy.png -t "${pkgdir}"/usr/share/pixmaps/
87 install -Dm 644 ../LICENSE.txt -t "${pkgdir}"/usr/share/licenses/renpy/
90 package_renpy-demos() {
94 install -dm 755 "${pkgdir}"/usr/share/renpy
95 cp -dr --no-preserve=ownership the_question tutorial "${pkgdir}"/usr/share/renpy/
96 install -dm 755 "${pkgdir}"/usr/share/licenses
97 ln -s renpy "${pkgdir}"/usr/share/licenses/renpy-demos