1 # Maintainer: Torsten Keßler <tpkessler at archlinux dot org>
2 # Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
6 pkgdesc='Port of the Thrust parallel algorithm library atop HIP/ROCm'
8 url='https://docs.amd.com/bundle/rocTHRUST_API_Guide/page/index.html'
10 depends=('hip' 'rocprim')
11 makedepends=('rocm-cmake')
12 _git='https://github.com/ROCmSoftwarePlatform/rocThrust'
13 source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
14 sha256sums=('c031f71cd4b6eaf98664fd2ad50fc18f7ccbfa67be415dca425169d2d1c81e9e')
15 _dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
18 # -fcf-protection is not supported by HIP, see
19 # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.5/page/Compiler_Options_and_Features.html#d2e2018
20 CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
25 -DCMAKE_BUILD_TYPE=None \
26 -DCMAKE_CXX_COMPILER=/opt/rocm/bin/hipcc \
27 -DCMAKE_INSTALL_PREFIX=/opt/rocm \
28 -Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr
33 DESTDIR="$pkgdir" cmake --install build