upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / jupyterlab / trunk / PKGBUILD
blob2e7925c8f5130f715ea774ab32e7d86d8024c4e5
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=jupyterlab
4 _pipname=jupyterlab
5 pkgver=4.0.0
6 pkgrel=1
7 pkgdesc='JupyterLab computational environment'
8 arch=(any)
9 url='https://github.com/jupyterlab/jupyterlab'
10 license=(custom)
11 makedepends=(python-build python-installer python-hatch-jupyter-builder)
12 depends=(python-jupyterlab_server python-jupyter_packaging python-async-lru jupyter-server-ydoc nodejs)
13 optdepends=('npm: to install extensions' 'jupyterlab-widgets: ipywidgets support')
14 checkdepends=(python-pytest-tornasync python-pytest-jupyter npm python-jupyter-server-terminals)
15 source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz)
16 sha256sums=('ce656d04828b2e4ee0758e22c862cc99aedec66a10319d09f0fd5ea51be68dd8')
18 build() {
19   cd $pkgname-$pkgver
20   python -m build --wheel --no-isolation
23 check() {
24   cd $pkgname-$pkgver
25   python -m venv --system-site-packages test-env
26   test-env/bin/python -m installer dist/*.whl
27   test-env/bin/python -m pytest -v
30 package() {
31   cd $pkgname-$pkgver
32   python -m installer --destdir="$pkgdir" dist/*.whl
33   mv "$pkgdir"/usr/etc "$pkgdir"
35   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE