upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / libskk / repos / community-x86_64 / PKGBUILD
blob796668f2bc9383d6f9fc7dd0bebe9b1f0c2fa96e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: eagletmt <eagletmt@gmail.com>
3 # Contributor: kusanaginoturugi <kusanaginoturugi@gmail.com>
5 pkgname=libskk
6 pkgver=1.0.5
7 pkgrel=2
8 pkgdesc='GObject-based library to deal with Japanese kana-to-kanji conversion method'
9 arch=('x86_64')
10 url='https://github.com/ueno/libskk'
11 license=('GPL3')
12 depends=('libgee' 'libxkbcommon' 'json-glib')
13 makedepends=('intltool' 'gnome-common' 'gobject-introspection' 'vala')
14 source=("$pkgname-$pkgver.tar.gz::https://github.com/ueno/libskk/archive/$pkgver.tar.gz")
15 sha512sums=('50b07b244e1fbec13764ca00b90ede2584c53dd5c16783c9bb9114f69f43dbebd352653f335f1c3584b8c42ef4184e891e0ca7427c38afc99131196721e1c1c1')
17 build() {
18   cd $pkgname-$pkgver
19   ./autogen.sh --prefix=/usr
20   make
23 check() {
24   cd $pkgname-$pkgver
25   make check
28 package() {
29   cd $pkgname-$pkgver
30   make DESTDIR="$pkgdir" install
33 # vim:set ts=2 sw=2 et: