1 # Maintainer: Santiago Torres-Arias <santiago -> a.o >
2 # Maintainer: Nick Black <dankamongmen@gmail.com>
7 pkgdesc="Blingful TUI/character graphics library"
8 url="https://nick-black.com/dankwiki/index.php/Notcurses"
11 # TODO: package qrcodegen
35 provides=(libnotcurses++.so libnotcurses.so libnotcurses-core.so)
36 source=("https://github.com/dankamongmen/notcurses/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
37 sha256sums=('e5cc02aea82814b843cdf34dedd716e6e1e9ca440cf0f899853ca95e241bd734')
38 b2sums=('718a5a36ed17d9118690ffdce3b2233144de0b8421a37429f1a20ae735215a87be9c308876c97d8a5126238fee76e470429837c7f224e8f020c60ad6b88514bd')
43 -DCMAKE_INSTALL_PREFIX=/usr
44 -DCMAKE_BUILD_TYPE=None
52 cmake "${cmake_options[@]}"
54 cd $pkgname-$pkgver/cffi
55 CFLAGS+=" -I$srcdir/$pkgname-$pkgver/include -L$srcdir/build" python -m build --wheel --no-isolation
59 ctest --test-dir build --output-on-failure
64 'ffmpeg' 'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libswscale.so'
66 'libdeflate' 'libdeflate.so'
67 'libunistring' 'libunistring.so'
68 'ncurses' 'libncursesw.so'
72 DESTDIR="$pkgdir" cmake --install build
73 python -m installer --destdir="$pkgdir" $pkgname-$pkgver/cffi/dist/*.whl