1 # Maintainer: Daniel M. Capella <polyzen@archlinux.org>
2 # Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
5 pkgname=python-aiostream
8 pkgdesc="Generator-based operators for asynchronous iteration"
10 url=https://github.com/vxgmichel/aiostream
13 makedepends=('git' 'python-build' 'python-installer' 'python-setuptools'
15 checkdepends=('python-pytest' 'python-pytest-asyncio')
16 source=("git+$url.git#tag=v$pkgver")
21 python -m build --wheel --skip-dependency-check --no-isolation
26 python -m venv --system-site-packages test-env
27 test-env/bin/python -m installer dist/*.whl
28 test-env/bin/python -m pytest tests --strict-markers -c /dev/null
33 python -m installer --destdir="$pkgdir" dist/*.whl