upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / python-psycopg / trunk / PKGBUILD
blob6e347353374fa1813fc2b9d45264d7a01d117462
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Guillaume Horel <guillaume.horel@gmail.com>
4 pkgname=python-psycopg
5 pkgver=3.1.9
6 pkgrel=1
7 pkgdesc='PostgreSQL database adapter for Python'
8 arch=('any')
9 url='https://www.psycopg.org/psycopg3/'
10 license=('LGPL3')
11 depends=('python' 'postgresql-libs')
12 makedepends=(
13   'git'
14   'python-build'
15   'python-installer'
16   'python-wheel'
17   'python-setuptools'
19 checkdepends=('python-pytest' 'python-pytest-asyncio')
20 _commit='b98f35a06397e3cb8d35e210738b9a49c9496e67'
21 source=("$pkgname::git+https://github.com/psycopg/psycopg.git#commit=$_commit")
22 b2sums=('SKIP')
24 pkgver() {
25   cd "$pkgname"
27   git describe --tags | sed 's/^v//'
30 build(){
31   cd "$pkgname/psycopg"
33   python -m build --wheel --no-isolation
36 package(){
37   cd "$pkgname/psycopg"
39   python -m installer --destdir="$pkgdir" dist/*.whl