1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=python-puremagic
6 pkgdesc="A Python module that will identify a file based off it's magic numbers"
8 url='https://github.com/cdgriffith/puremagic'
18 checkdepends=('python-pytest')
19 _commit='ff042db17e7477bbabcb9c5b7e8562a697f6b1cb'
20 source=("$pkgname::git+$url#commit=$_commit")
26 git describe --tags | sed 's/^v//'
32 python -m build --wheel --no-isolation
38 PYTHONPATH="$PWD:$PYTHONPATH" pytest
44 python -m installer --destdir="$pkgdir" dist/*.whl
47 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE