upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / python-traitsui / trunk / PKGBUILD
blob553e8449f99a4fed8b1137945974d5bcc6974c41
1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
3 pkgname=python-traitsui
4 pkgver=7.4.3
5 pkgrel=2
6 pkgdesc="Traits-capable user interfaces"
7 arch=('any')
8 url="https://github.com/enthought/traitsui"
9 license=('BSD')
10 depends=('python-pyface')
11 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
12 source=("traitsui-${pkgver}.tar.gz::https://github.com/enthought/traitsui/archive/${pkgver}.tar.gz")
13 sha256sums=('587da5de6b6000a9ec520e3860dd20c030c1a987814cde90d803bc06918aa32d')
15 build() {
16   cd traitsui-$pkgver
17   python -m build --wheel --no-isolation
20 package() {
21   cd traitsui-$pkgver
22   python -m installer --destdir="$pkgdir" dist/*.whl
23   install -D LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE