archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-groups / repos / community-x86_64 / PKGBUILD
blob7b9f1e144bb0d24ab3dfebda81a2e666d1a7f7bb
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=groups
4 pkgname=haskell-groups
5 pkgver=0.5.3
6 pkgrel=1
7 pkgdesc="Groups"
8 url="https://github.com/Taneb/groups.git"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('ce1e52a8be7effbd1f995eadf0ed34fa45c412656d372db8a38f9c955e43ac38')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie'
25   runhaskell Setup build
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 package() {
33   cd $_hkgname-$pkgver
35   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
36   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
37   runhaskell Setup copy --destdir="$pkgdir"
38   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
39   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE