archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-html-conduit / repos / community-x86_64 / PKGBUILD
blobd18a74dda5eb2ff07674b052c1f110c897086108
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=html-conduit
4 pkgname=haskell-html-conduit
5 pkgver=1.3.2.2
6 pkgrel=160
7 pkgdesc="Parse HTML documents using xml-conduit datatypes"
8 url="https://github.com/snoyberg/xml"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-resourcet' 'haskell-conduit' 'haskell-xml-conduit'
12          'haskell-attoparsec' 'haskell-conduit-extra' 'haskell-xml-types')
13 makedepends=('ghc' 'haskell-hspec' 'haskell-hunit')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('474bfeec36d0f2fe8eb37ed88372d456800e8d28e499e5ffe222170db794eba292938800e145613334d1e11d2e6b78195b6dd7a0d3cd92e2fa3f348ad8d18489')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 check() {
31     cd $_hkgname-$pkgver
32     runhaskell Setup test --show-details=direct
35 package() {
36     cd $_hkgname-$pkgver
37     
38     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40     runhaskell Setup copy --destdir="$pkgdir"
41     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE