archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-persistent-template / trunk / PKGBUILD
blob2f291cd9c54fa661b70e6aa8b73d0a188f4d8cc4
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=persistent-template
5 pkgname=haskell-persistent-template
6 pkgver=2.9.1.0
7 pkgrel=97
8 pkgdesc="Type-safe, non-relational, multi-backend persistence"
9 url="http://www.yesodweb.com/book/persistent"
10 license=("MIT")
11 arch=('x86_64')
12 depends=('ghc-libs' "haskell-aeson" "haskell-http-api-data" "haskell-monad-control"
13          "haskell-monad-logger" "haskell-path-pieces" "haskell-persistent"
14          'haskell-th-lift-instances' "haskell-unordered-containers")
15 makedepends=('ghc' 'haskell-hspec')
16 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
17 sha512sums=('56c89b4f02401cbf9716b97c4c314d6ef079dccf75ec1166f9b2b641049723002587fd5d074c1a87d20f7162d8b5677a87c84a1e4333eb93c425a5f09c84ea64')
19 build() {
20     cd $_hkgname-$pkgver
22     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
23         --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
24         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
25     runhaskell Setup build $MAKEFLAGS
26     runhaskell Setup register --gen-script
27     runhaskell Setup unregister --gen-script
28     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33     cd $_hkgname-$pkgver
34     runhaskell Setup test --show-details=direct
37 package() {
38     cd $_hkgname-$pkgver
40     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42     runhaskell Setup copy --destdir="$pkgdir"
43     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
44     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE