archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-pgp-wordlist / repos / community-x86_64 / PKGBUILD
blobe6c9ac53ba4faec290ffdcca0727dbfd76c5409b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=pgp-wordlist
4 pkgname=haskell-pgp-wordlist
5 pkgver=0.1.0.3
6 pkgrel=212
7 pkgdesc="Translate between binary data and a human-readable collection of words."
8 url="https://github.com/quchen/pgp-wordlist"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-vector')
12 makedepends=('ghc' 'haskell-doctest' 'haskell-hunit' 'haskell-tasty' 'haskell-tasty-hunit'
13              'haskell-tasty-quickcheck')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('b7c6db47c1f9a0b10c5c94ea46b8eee282988e5990ef3dafa2d07a5bfc0718572b04494d23ddab063811ef2452546d6b17010c6490a89031f4b071f1a43d989b')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 check() {
31     cd $_hkgname-$pkgver
32     runhaskell Setup test --show-details=direct
35 package() {
36     cd $_hkgname-$pkgver
37     
38     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40     runhaskell Setup copy --destdir="$pkgdir"
41     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE