archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-serialise / trunk / PKGBUILD
blob511cfb99713278cf279506bfb452f8c98e008fbd
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=serialise
4 pkgname=haskell-serialise
5 pkgver=0.2.6.0
6 pkgrel=38
7 pkgdesc="A binary serialisation library for Haskell values"
8 url="https://github.com/well-typed/cborg"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-cborg' 'haskell-half' 'haskell-hashable' 'haskell-primitive'
12          'haskell-strict' 'haskell-these' 'haskell-unordered-containers' 'haskell-vector')
13 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-quickcheck-instances' 'haskell-tasty'
14              'haskell-tasty-hunit' 'haskell-tasty-quickcheck')
15 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
16 sha512sums=('708e6a735d6569d9959026cdf08030a270c0b703e3e2e08c5e379e63aff81bece27bc43d492a867fd073d8a7ccf4bce570acc822478899b01b960403865c3616')
18 prepare() {
19     cd $_hkgname-$pkgver
20     uusi -u vector $_hkgname.cabal
23 build() {
24     cd $_hkgname-$pkgver
26     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
28         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
29     runhaskell Setup build $MAKEFLAGS
30     runhaskell Setup register --gen-script
31     runhaskell Setup unregister --gen-script
32     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 check() {
37     cd $_hkgname-$pkgver
38     runhaskell Setup test --show-details=direct
41 package() {
42     cd $_hkgname-$pkgver
44     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
45     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
46     runhaskell Setup copy --destdir="$pkgdir"
47     install -D -m644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname/
48     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE.txt