1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=tamarin-prover-sapic
4 pkgname=haskell-tamarin-prover-sapic
7 pkgdesc="Library for input processes in SAPIC calculus for the tamarin prover"
8 url="http://www.infsec.ethz.ch/research/software/tamarin"
11 depends=('ghc-libs' 'haskell-aeson' 'haskell-aeson-pretty' 'haskell-dlist' 'haskell-fclabels'
12 'haskell-parallel' 'haskell-safe' 'haskell-uniplate' 'haskell-raw-strings-qq'
13 'haskell-tamarin-prover-utils' 'haskell-tamarin-prover-term' 'haskell-tamarin-prover-theory')
15 source=("tamarin-prover-$pkgver.tar.gz::https://github.com/tamarin-prover/tamarin-prover/archive/$pkgver.tar.gz")
16 sha512sums=('dc6b91b1669055913a0aefc9a969812bf252185480fbf67588e7458289b1e1b64bf0729e9bee043513ecd5a57cd0c9477512e80861c6956c08b5e29d90211f62')
19 cd tamarin-prover-$pkgver/lib/sapic
20 echo -e "import Distribution.Simple\nmain = defaultMain" > Setup.hs
24 cd tamarin-prover-$pkgver/lib/sapic
26 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
28 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
29 runhaskell Setup build $MAKEFLAGS
30 runhaskell Setup register --gen-script
31 runhaskell Setup unregister --gen-script
32 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 cd tamarin-prover-$pkgver/lib/sapic
39 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
40 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
41 runhaskell Setup copy --destdir="$pkgdir"
42 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE