archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-template-haskell-compat-v0208 / repos / community-x86_64 / PKGBUILD
blob64da5795fd2e40694a9928361c6ca4c625013c5a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=template-haskell-compat-v0208
4 pkgname=haskell-template-haskell-compat-v0208
5 pkgver=0.1.9.2
6 pkgrel=1
7 pkgdesc="A backwards compatibility layer for Template Haskell newer than 2.8"
8 url="https://github.com/nikita-volkov/template-haskell-compat-v0208"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc' 'uusi')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('5b39c7c8d55046ba8127b0c8772bac2515255cb9cc68cc404cbb050cc19cca85e18c1c2e4baf9670980109a2b0fe543d3c9c48a6c9c8a5af4cdf66c6ccef9058')
16 prepare() {
17     cd $_hkgname-$pkgver
18     gen-setup
21 build() {
22     cd $_hkgname-$pkgver
24     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
27     runhaskell Setup build $MAKEFLAGS
28     runhaskell Setup register --gen-script
29     runhaskell Setup unregister --gen-script
30     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35     cd $_hkgname-$pkgver
36     runhaskell Setup test --show-details=direct
39 package() {
40     cd $_hkgname-$pkgver
42     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44     runhaskell Setup copy --destdir="$pkgdir"
45     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
46     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE