1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=template-haskell-compat-v0208
4 pkgname=haskell-template-haskell-compat-v0208
7 pkgdesc="A backwards compatibility layer for Template Haskell newer than 2.8"
8 url="https://github.com/nikita-volkov/template-haskell-compat-v0208"
12 makedepends=('ghc' 'uusi')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('5b39c7c8d55046ba8127b0c8772bac2515255cb9cc68cc404cbb050cc19cca85e18c1c2e4baf9670980109a2b0fe543d3c9c48a6c9c8a5af4cdf66c6ccef9058')
24 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
27 runhaskell Setup build $MAKEFLAGS
28 runhaskell Setup register --gen-script
29 runhaskell Setup unregister --gen-script
30 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 runhaskell Setup test --show-details=direct
42 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44 runhaskell Setup copy --destdir="$pkgdir"
45 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
46 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE