archrelease: copy trunk to community-any
[ArchLinux/community.git] / lib32-alsa-plugins / trunk / PKGBUILD
blob5ae2f4d0ef3b625df0f9192130008e6282a04028
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
4 _name=alsa-plugins
5 pkgname=lib32-alsa-plugins
6 pkgver=1.2.7.1
7 pkgrel=2
8 pkgdesc="Additional ALSA plugins (32-bit)"
9 arch=(x86_64)
10 url="https://www.alsa-project.org"
11 license=(LGPL2.1)
12 depends=(
13   "alsa-plugins=1:$pkgver"
14   lib32-alsa-lib
15   lib32-glibc
17 makedepends=(
18   lib32-libavtp
19   lib32-dbus
20   lib32-jack
21   lib32-libpulse
22   lib32-libsamplerate
23   lib32-speexdsp
25 optdepends=(
26   'lib32-dbus: for maemo plugin'
27   'lib32-jack: for pcm_jack plugin'
28   'lib32-libavtp: for pcm_aaf plugin'
29   'lib32-libsamplerate: for rate_samplerate plugin'
30   'lib32-libpulse: for conf_pulse, ctl_pulse and pcm_pulse plugins'
31   'lib32-speexdsp: for pcm_speex and rate_speexrate plugins'
33 source=(https://www.alsa-project.org/files/pub/plugins/$_name-$pkgver.tar.bz2{,.sig})
34 sha512sums=('437c05a7e0175594768fd6a9a6d1a158bb4a01a7de6a42c2bd468d9381e01b64d385ddfac7d87baf84fe13cb4e65dc24da643940f416d4b191c528728822d964'
35             'SKIP')
36 b2sums=('6f7aa503eda879cd273f36a16eec702b4da9267a60835cb5acbbfe355a83b7ffa3e93eb6483c9946c1d0bcd845a8f574470e7b84c66f793d0d0c6c9883ad52ee'
37         'SKIP')
38 validpgpkeys=('F04DF50737AC1A884C4B3D718380596DA6E59C91') # ALSA Release Team (Package Signing Key v1) <release@alsa-project.org>
40 prepare() {
41   cd $_name-$pkgver
42   autoreconf -fiv
45 build() {
46   local configure_options=(
47     --prefix=/usr
48     --libdir=/usr/lib32
49     --sysconfdir=/etc
50     --enable-maemo-plugin
51   )
53   cd $_name-$pkgver
55   export CC='gcc -m32'
56   export PKG_CONFIG=i686-pc-linux-gnu-pkg-config
58   ./configure "${configure_options[@]}"
59   make
62 package() {
63   depends+=(
64     lib32-alsa-lib libasound.so
65   )
67   make DESTDIR="$pkgdir" install -C $_name-$pkgver
68   rm -rv "$pkgdir"/{etc,usr/share}
70 # vim:set sw=2 et: