archrelease: copy trunk to community-any
[ArchLinux/community.git] / modest / trunk / PKGBUILD
blob9ef1ccc531998410db72dc9b55250819526639cd
1 # Maintainer: Robin Broda <robin at broda dot me>
3 _commit='d021b907517d0be30bd709dc9649bc9b54e4b4f4'
5 pkgname=modest
6 pkgver=0.0.6.${_commit:0:7}
7 pkgrel=3
8 pkgdesc='Fast HTML renderer implemented as a pure C99 library with no outside dependencies'
9 arch=('x86_64')
10 url='https://github.com/lexborisov/modest'
11 license=('LGPL2.1')
12 makedepends=('git')
13 source=("git+${url}#commit=${_commit}")
14 md5sums=('SKIP')
15 provides=('mycore' 'mycss' 'myencoding' 'myfont' 'myhtml' 'myunicode' 'myurl')
17 build() {
18         cd "${pkgname}"
20         make CFLAGS="$CFLAGS -Wno-variadic-macros -ffat-lto-objects" prefix="/usr"
23 check() {
24         cd "${pkgname}"
26         make test
29 package() {
30         cd "${pkgname}"
32         make DESTDIR="${pkgdir}/" prefix="/usr" install