archrelease: copy trunk to community-any
[ArchLinux/community.git] / peony / repos / community-x86_64 / PKGBUILD
blob4fa352d2666280a6ffabe38083627fc4693a559a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=peony
4 pkgver=3.2.3
5 pkgrel=1
6 pkgdesc="File manager for the UKUI desktop"
7 arch=('x86_64')
8 license=('GPL')
9 url="https://github.com/ukui/peony"
10 depends=('gsettings-qt' 'kwayland' 'kwindowsystem' 'libcanberra' 'libnotify' 'poppler-qt5'
11          'qt5-ukui-platformtheme' 'qt5-x11extras' 'udisks2')
12 makedepends=('qt5-tools')
13 groups=('ukui')
14 source=("https://github.com/ukui/peony/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
15 sha512sums=('352e533538ed900f4e38f06634f9a2709161f6b0b27f66765ddf0b97abea6c72289465688065511cf667bacd5f325be0a1e0fda49ece213f4aefaf181285a7d0')
17 build() {
18   cd peony-$pkgver
19   qmake-qt5
20   make
23 package() {
24   cd peony-$pkgver
25   make INSTALL_ROOT="$pkgdir" install
27   install -Dm644 data/peony{,-computer,-home,-trash}.desktop -t "$pkgdir"/usr/share/applications/
28   install -Dm644 data/peony-desktop.desktop -t "$pkgdir"/etc/xdg/autostart/