archrelease: copy trunk to community-any
[ArchLinux/community.git] / perl-file-chdir / trunk / PKGBUILD
blob2bddacf7f7f70bcc6ad5471f4b1dd0366895233c
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Maintainer: Charles Mauch <cmauch@gmail.com>
3 # Contributor: Francois Charette <firmicus@gmx.net>
5 pkgname=perl-file-chdir
6 pkgver=0.1011
7 pkgrel=4
8 pkgdesc="a more sensible way to change directories "
9 arch=('any')
10 depends=('perl')
11 url="https://search.cpan.org/dist/File-chdir"
12 license=('GPL' 'PerlArtistic')
13 options=('!emptydirs')
14 source=(https://www.cpan.org/authors/id/D/DA/DAGOLDEN/File-chdir-$pkgver.tar.gz)
15 sha256sums=('31ebf912df48d5d681def74b9880d78b1f3aca4351a0ed1fe3570b8e03af6c79')
17 build() {
18   cd  "$srcdir"/File-chdir-$pkgver
19   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
20   make
23 package() {
24   cd  "$srcdir"/File-chdir-$pkgver
25   make install DESTDIR="$pkgdir"
26   find "$pkgdir" -name '.packlist' -delete
27   find "$pkgdir" -name '*.pod' -delete