archrelease: copy trunk to community-any
[ArchLinux/community.git] / perl-lchown / trunk / PKGBUILD
blob54e33d75a110ed6ed1b0b50f54ec1db22f0513c1
1 # Maintainer: Florian Pritz <bluewind@xinu.at>
3 pkgname=perl-lchown
4 pkgver=1.01
5 pkgrel=14
6 pkgdesc="use the lchown(2) system call from Perl"
7 arch=(x86_64)
8 license=(PerlArtistic GPL)
9 options=(!emptydirs)
10 depends=('perl')
11 makedepends=('perl-module-build')
12 url=https://metacpan.org/release/Lchown
13 source=("https://search.cpan.org/CPAN/authors/id/N/NC/NCLEATON/Lchown-${pkgver}.tar.gz")
14 sha256sums=('9c0a13e279ad92208fb8fac73001635b0689251dd41b597522e1b3501ba0f76f')
16 build() {
17     export PERL_MM_USE_DEFAULT=1 PERL5LIB=""                 \
18       PERL_AUTOINSTALL=--skipdeps                            \
19       PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='"$pkgdir"'"     \
20       PERL_MB_OPT="--installdirs vendor --destdir '"$pkgdir"'" \
21       MODULEBUILDRC=/dev/null
23     cd "${srcdir}/Lchown-${pkgver}"
24     /usr/bin/perl Build.PL
25     ./Build
28 check() {
29     export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
30     cd "${srcdir}/Lchown-${pkgver}"
31     ./Build test
34 package() {
35     cd "${srcdir}/Lchown-${pkgver}"
36     ./Build install
37     find "$pkgdir" -name .packlist -o -name perllocal.pod -delete