archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-mutatormath / trunk / PKGBUILD
blob3cfb626a0a4453920bbafc598e5e82694ec7c26f
1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Contributor: Guillaume Horel <guillaume.horel@gmail.com>
3 # Contributor: William Turner <willtur.will@gmail.com>
5 pkgname=python-mutatormath
6 _pkgname=MutatorMath
7 pkgver=3.0.1
8 pkgrel=4
9 pkgdesc='Piecewise linear interpolation of multiple, arbitrarily placed, masters'
10 arch=(any)
11 url="https://github.com/LettError/$_pkgname"
12 license=(BSD)
13 depends=(python
14          python-defcon
15          python-fontmath
16          python-fonttools)
17 makedepends=(python-{build,installer,wheel}
18              python-setuptools)
19 _archive="$_pkgname-$pkgver"
20 source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_archive.zip")
21 sha256sums=('8127c1ffad1646f11a953752296c43f5d88cbd5293fff03f093d916b0bc13864')
23 build() {
24         cd "$_archive"
25         python -m build -wn
28 check() {
29         cd "$_archive"
30         python -m unittest discover
33 package() {
34         cd "$_archive"
35         python -m installer -d "$pkgdir" dist/*.whl
36         install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE