1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-pytest-xdist
5 _commit=f5b4a5d6edea6a9eb016730f5de0aae8cbc9930e
7 pkgdesc='py.test xdist plugin for distributed testing and loop-on-failing modes'
10 url='https://github.com/pytest-dev/pytest-xdist'
11 depends=('python-execnet' 'python-pytest')
12 makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
13 checkdepends=('python-filelock' 'python-psutil')
14 source=("git+https://github.com/pytest-dev/pytest-xdist.git#commit=$_commit")
23 # Hack entry points by installing it
26 python -m installer -d "$PWD/tmp_install" dist/*.whl
27 local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
28 PYTHONPATH="$PWD/tmp_install$site_packages:$PYTHONPATH" pytest
33 python -m installer -d "$pkgdir" dist/*.whl
34 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
37 # vim:set ts=2 sw=2 et: