archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-pytrie / trunk / PKGBUILD
blobd9084c1bb1dffd77e9f5e519b310a071f77dc19d
1 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
2 # Modified from aur/python2-pytrie; original maintainership info:
3 # Contributor: dseg
5 pkgname=python-pytrie
6 pkgver=0.4.0
7 pkgrel=6
8 pkgdesc="A pure Python implementation of the trie data structure."
9 url="https://github.com/gsakkis/pytrie/"
10 depends=(python python-sortedcontainers)
11 makedepends=(python-setuptools)
12 # Tests in this package imports tests from CPython :/
13 checkdepends=(python-tests)
14 license=(BSD)
15 arch=(any)
16 source=("https://files.pythonhosted.org/packages/source/P/PyTrie/PyTrie-$pkgver.tar.gz")
17 sha256sums=('8f4488f402d3465993fb6b6efa09866849ed8cda7903b50647b7d0342b805379')
19 build() {
20   cd PyTrie-$pkgver
21   python setup.py build
24 check() {
25   cd PyTrie-$pkgver
26   python -m unittest discover -v ./tests
29 package() {
30   cd PyTrie-$pkgver
31   python setup.py install --root="$pkgdir" --optimize=1 --skip-build
32   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/