1 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
2 # Modified from aur/python2-pytrie; original maintainership info:
8 pkgdesc="A pure Python implementation of the trie data structure."
9 url="https://github.com/gsakkis/pytrie/"
10 depends=(python python-sortedcontainers)
11 makedepends=(python-setuptools)
12 # Tests in this package imports tests from CPython :/
13 checkdepends=(python-tests)
16 source=("https://files.pythonhosted.org/packages/source/P/PyTrie/PyTrie-$pkgver.tar.gz")
17 sha256sums=('8f4488f402d3465993fb6b6efa09866849ed8cda7903b50647b7d0342b805379')
26 python -m unittest discover -v ./tests
31 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
32 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/