archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-webtest-aiohttp / repos / community-any / PKGBUILD
blob73a9690c3f94c6ec25151f2e95d24f66e488ecf9
1 # Maintainer:
3 pkgname=python-webtest-aiohttp
4 pkgver=2.0.0
5 pkgrel=3
6 pkgdesc='Provides integration of WebTest with aiohttp.web applications'
7 arch=(any)
8 url='https://github.com/sloria/webtest-aiohttp'
9 license=(MIT)
10 depends=(python)
11 makedepends=(python-build python-installer python-setuptools python-wheel)
12 checkdepends=(python-pytest)
13 _name=${pkgname/python-/}
14 source=(https://pypi.python.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz)
15 sha256sums=('58e2a2f13078c3f1f23ccebef03de4d6d118d096cd6e9d0d190e359d9ffb11f8')
17 build() {
18   cd $_name-$pkgver
19   python -m build --wheel --no-isolation
22 package() {
23   cd $_name-$pkgver
24   python -m installer --destdir="$pkgdir" dist/*.whl
26   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname