3 pkgname=python-webtest-aiohttp
6 pkgdesc='Provides integration of WebTest with aiohttp.web applications'
8 url='https://github.com/sloria/webtest-aiohttp'
11 makedepends=(python-build python-installer python-setuptools python-wheel)
12 checkdepends=(python-pytest)
13 _name=${pkgname/python-/}
14 source=(https://pypi.python.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz)
15 sha256sums=('58e2a2f13078c3f1f23ccebef03de4d6d118d096cd6e9d0d190e359d9ffb11f8')
19 python -m build --wheel --no-isolation
24 python -m installer --destdir="$pkgdir" dist/*.whl
26 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname