archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-whatthepatch / trunk / PKGBUILD
blobffb53e7aedccfc1cef6acba41d111c9227974ad3
1 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 _pkg=whatthepatch
4 pkgname=python-${_pkg}
5 pkgver=1.0.4
6 pkgrel=2
7 pkgdesc="A Python patch parsing library"
8 arch=(any)
9 url="https://github.com/cscorley/whatthepatch"
10 license=(MIT)
11 depends=(python)
12 makedepends=(python-build python-installer python-setuptools python-wheel)
13 checkdepends=(python-pytest)
14 source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
15 #source=(${url}/archive/v${pkgver}rel/${pkgname}-${pkgver}.tar.gz)
16 sha256sums=('e95c108087845b09258ddfaf82aa13cf83ba8319475117c0909754ca8b54d742')
18 build() {
19   cd ${_pkg}-${pkgver}
20   python -m build --wheel --no-isolation
23 check() {
24   cd ${_pkg}-${pkgver}
25   PYTHONPATH="${PWD}"/build/lib/ pytest -vv --color=yes
28 package() {
29   cd ${_pkg}-${pkgver}
30   python -m installer --destdir="${pkgdir}" dist/*.whl
31   install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}