1 # Maintainer: Bruno Pagani <archange@archlinux.org>
7 pkgdesc="A Python patch parsing library"
9 url="https://github.com/cscorley/whatthepatch"
12 makedepends=(python-build python-installer python-setuptools python-wheel)
13 checkdepends=(python-pytest)
14 source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
15 #source=(${url}/archive/v${pkgver}rel/${pkgname}-${pkgver}.tar.gz)
16 sha256sums=('e95c108087845b09258ddfaf82aa13cf83ba8319475117c0909754ca8b54d742')
20 python -m build --wheel --no-isolation
25 PYTHONPATH="${PWD}"/build/lib/ pytest -vv --color=yes
30 python -m installer --destdir="${pkgdir}" dist/*.whl
31 install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}