archrelease: copy trunk to community-any
[ArchLinux/community.git] / qstopmotion / trunk / PKGBUILD
blob9c8c60595b346bb021d3561d90a5875afc7bc772
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgname=qstopmotion
4 pkgver=2.5.2
5 pkgrel=2
6 pkgdesc='Application for creating stop-motion animation movies'
7 url='http://qstopmotion.org/'
8 license=('GPL2')
9 arch=('x86_64')
10 depends=('ffmpeg' 'libgphoto2' 'qt5-multimedia' 'qwt' 'v4l-utils')
11 makedepends=('cmake' 'ninja')
12 source=("https://downloads.sourceforge.net/$pkgname/Version_${pkgver//./_}/$pkgname-$pkgver-Source.tar.gz"
13         'qstopmotion.appdata.xml')
14 sha256sums=('8f2054c9a7644ae40a5ceaebe576758f2ea87f5430f12d873f1b8eacf73b4671'
15             'fd0c4a63f3cd407143257141ab50cacd500821ded2ba1141a6b54def3490b3f1')
17 build() {
18   cmake -S $pkgname-$pkgver-Source -B build -G Ninja -DCMAKE_INSTALL_PREFIX='/usr'
19   cmake --build build
22 package() {
23   DESTDIR="$pkgdir" cmake --install build
24   install -Dm644 $pkgname.appdata.xml "$pkgdir/usr/share/metainfo/$pkgname.appdata.xml"