archrelease: copy trunk to community-any
[ArchLinux/community.git] / uvicorn / trunk / PKGBUILD
blob8df2ea7f383e1bf12b7902070a152221b1860d5f
1 # Maintainer: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
2 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
4 pkgname=uvicorn
5 pkgver=0.22.0
6 pkgrel=3
7 pkgdesc='The lightning-fast ASGI server'
8 arch=(any)
9 url=https://github.com/encode/uvicorn
10 license=(BSD)
11 depends=(
12   python
13   python-asgiref
14   python-click
15   python-h11
16   python-httptools
17   python-uvloop
18   python-websockets
20 makedepends=(
21   git
22   python-build
23   python-hatchling
24   python-installer
26 _tag=71043a9c8fb6436a63110179650e32bcae4a6cbf
27 source=(git+https://github.com/encode/uvicorn#tag=${_tag})
28 b2sums=(SKIP)
30 pkgver() {
31   cd uvicorn
32   git describe --tags
35 build() {
36   cd uvicorn
37   python -m build --wheel --no-isolation
40 package() {
41   python -m installer --destdir="${pkgdir}" uvicorn/dist/*.whl
42   install -Dm 644 uvicorn/LICENSE.md -t "${pkgdir}"/usr/share/licenses/uvicorn/
45 # vim:set ts=2 sw=2 et: