archrelease: copy trunk to community-any
[ArchLinux/community.git] / xed / trunk / PKGBUILD
blob60cebf92c2d50bf0082c0a5d141b24e40b8dcef9
1 # Maintainer: Bruno Pagani <archange@archlinux.org>
2 # Contributor: Eli Schwartz <eschwartz@archlinux.org>
3 # Contributor: Nate Simon <aurpkg (at natesimon.net)>
5 pkgname=xed
6 pkgver=3.2.8
7 pkgrel=1
8 pkgdesc="A small and lightweight text editor. X-Apps Project."
9 arch=(x86_64)
10 url="https://github.com/linuxmint/${pkgname}"
11 license=(GPL)
12 groups=(x-apps)
13 depends=(gspell gtksourceview4 libpeas xapp)
14 makedepends=(meson samurai gobject-introspection intltool itstool)
15 optdepends=('python: required for some plugins')
16 source=(${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
17 sha256sums=('682f7557674be8557b58e082e0f9643419be3dc17a777f90a0bd08850311f5d5')
18 b2sums=('b844ee8ac36ce0a68f83dbca5437c9062c90114e17ae8569b86849142bfff00d488bdc3988d48636ec082dd09f96e4750af40be3e8ec2e0b5ec82df035268c81')
20 build() {
21   arch-meson ${pkgname}-${pkgver} build
22   samu -C build
25 package(){
26   DESTDIR="${pkgdir}" samu -C build install