archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-basictracer / trunk / PKGBUILD
blobbd0b209b3d54057cf99fcedad51a6f5025ac09e1
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-basictracer
4 pkgver=3.2.0
5 pkgrel=3
6 pkgdesc='The Python implementation of the "BasicTracer" reference implementation'
7 url="https://github.com/opentracing/basictracer"
8 license=('MIT')
9 arch=('any')
10 depends=('python-opentracing' 'python-protobuf' 'python-six')
11 makedepends=('python-setuptools')
12 checkdepends=('python-mock' 'python-pytest')
13 source=("https://github.com/opentracing/basictracer-python/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('48923ca75b459401ab604174a62c611ea44c5904709260d0635dc0436f5c0d88b7564d2fcf68a3fd18f3825ba615347bed7e79a41f303745ca7de282bbd4c61c')
16 build() {
17   cd basictracer-python-$pkgver
18   python setup.py build
21 check() {
22   cd basictracer-python-$pkgver
23   pytest
26 package() {
27   cd basictracer-python-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1
30   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/