1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-basictracer
6 pkgdesc='The Python implementation of the "BasicTracer" reference implementation'
7 url="https://github.com/opentracing/basictracer"
10 depends=('python-opentracing' 'python-protobuf' 'python-six')
11 makedepends=('python-setuptools')
12 checkdepends=('python-mock' 'python-pytest')
13 source=("https://github.com/opentracing/basictracer-python/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('48923ca75b459401ab604174a62c611ea44c5904709260d0635dc0436f5c0d88b7564d2fcf68a3fd18f3825ba615347bed7e79a41f303745ca7de282bbd4c61c')
17 cd basictracer-python-$pkgver
22 cd basictracer-python-$pkgver
27 cd basictracer-python-$pkgver
28 python setup.py install --root="$pkgdir" --optimize=1
30 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/