1 # Maintainer: Kyle Keen <keenerd@gmail.com>
3 pkgname=python-entrypoints
7 pkgdesc="Discover and load entry points from installed packages."
9 url="https://github.com/takluyver/entrypoints"
12 makedepends=('python-build' 'python-installer' 'python-flit-core')
13 checkdepends=('python-pytest')
14 source=(https://github.com/takluyver/entrypoints/archive/$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('d2197a94aa73e70a7f60600e654ac9918ca2a0ee5480eb875296c42220a02272')
19 python -m build --wheel --no-isolation
29 python -m installer --destdir="$pkgdir" dist/*.whl
31 install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"