archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-pyquery / trunk / PKGBUILD
blob93baebbdae57fcc7c5801c9945c47852f0200b08
1 # Maintainer : Felix Yan <felixonmars@archlinux.org>
2 # Contributor: speps <speps at aur dot archlinux dot org>
3 # Contributor: Arnau Sanchez <tokland {at} gmail {dot} com>
5 pkgname=python-pyquery
6 pkgver=2.0.0
7 pkgrel=3
8 pkgdesc="A jquery-like library for python."
9 arch=('any')
10 url="https://github.com/gawel/pyquery/"
11 license=('BSD')
12 depends=('python-lxml' 'python-cssselect')
13 optdepends=('python-webob: query wsgi app')
14 makedepends=('python-setuptools')
15 checkdepends=('python-requests' 'python-webob' 'python-pytest' 'python-webtest')
16 source=("https://github.com/gawel/pyquery/archive/$pkgver/$pkgname-$pkgver.tar.gz")
17 sha512sums=('0c44ca00ee30922e72aff23764d4a6a8ab9f4df684de77703b69b87af4b461ee2338ef5fb134dce280926e2575b976a1b86d16b1234e13fc450811e4874a34e9')
19 build() {
20   cd pyquery-$pkgver
21   python setup.py build
24 check() {
25   cd pyquery-$pkgver
26   pytest
29 package() {
30   cd pyquery-$pkgver
31   python setup.py install -O1 --root="$pkgdir"
32   install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname/