ThirdParty packages: Fix typos for some .csh files. Add some comments in the etc...
[OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / openmpi-1.4.1.spec
blob861c518b59fb43f91b0d3d7557f323289deb7826
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #-------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for openmpi-1.4.1
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath %{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
57 # regenerate the RPM.
59 %define _prefix %{_WM_THIRD_PARTY_DIR}
61 %define name openmpi
62 %define release %{_WM_OPTIONS}
63 %define version 1.4.1
65 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
68 Summary: openmpi
69 License: Unkown
70 Name: %{name}
71 Version: %{version}
72 Release: %{release}
73 URL: http://www.open-mpi.org/software/ompi/v1.4/downloads
74 Source: %url/%{name}-%{version}.tar.gz
75 Prefix: %{_prefix}
76 Group: Development/Tools
79 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
81 %description
82 %{summary}
84 %prep
85 %setup -q
87 %build
88 # export WM settings in a form that GNU configure recognizes
89 [ -n "$WM_CC" ] && export CC="$WM_CC"
90 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
91 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
92 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
93 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
95 unset mpiWith
96 # enable GridEngine if it appears to be in use
97 if [ -n "$SGE_ROOT" ]
98 then
99 mpiWith="$mpiWith --with-sge"
102 # Infiniband support
103 # if [ -d /usr/local/ofed -a -d /usr/local/ofed/lib64 ]
104 # then
105 # mpiWith="$mpiWith --with-openib=/usr/local/ofed"
106 # mpiWith="$mpiWith --with-openib-libdir=/usr/local/ofed/lib64"
107 # fi
109 ./configure \
110 --prefix=$RPM_BUILD_ROOT%{_installPrefix} \
111 --disable-mpirun-prefix-by-default \
112 --disable-orterun-prefix-by-default \
113 --enable-shared --disable-static \
114 --disable-mpi-f77 \
115 --disable-mpi-f90 \
116 --disable-mpi-cxx \
117 --disable-mpi-profile \
118 $mpiWith \
121 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
122 make -j $WM_NCOMPPROCS
124 %install
125 make install prefix=$RPM_BUILD_ROOT%{_installPrefix}
127 # Creation of OpenFOAM specific .csh and .sh files"
129 echo ""
130 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
131 echo ""
133 # Generate package specific .sh file for OpenFOAM
135 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
136 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
137 # Load %{name}-%{version} libraries and binaries if available
138 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
140 export OPENMPI_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
142 [ -d \$OPENMPI_DIR/lib ] && _foamAddLib \$OPENMPI_DIR/lib
144 # Enable access to the package applications if present
145 [ -d \$OPENMPI_DIR/bin ] && _foamAddPath \$OPENMPI_DIR/bin
146 DOT_SH_EOF
149 # Generate package specific .csh file for OpenFOAM
151 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
152 # Load %{name}-%{version} libraries and binaries if available
153 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
154 setenv OPENMPI_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
156 if ( -e \$OPENMPI_DIR/lib ) then
157 _foamAddLib \$OPENMPI_DIR/lib
158 endif
160 if ( -e \$OPENMPI_DIR/bin ) then
161 _foamAddPath \$OPENMPI_DIR/bin
162 endif
163 DOT_CSH_EOF
165 %clean
166 rm -rf %{buildroot}
168 %files
169 %defattr(-,root,root)
170 %{_installPrefix}/*