ThirdParty: adjustments to path of generated .tgz files
[OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / openmpi-1.4.1.spec
blobed46b93c0c7097808d1f5e503a89d630227160b2
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for openmpi-1.4.1
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath %{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
57 # regenerate the RPM.
59 %define _prefix %{_WM_THIRD_PARTY_DIR}
61 %define name openmpi
62 %define release %{_WM_OPTIONS}
63 %define version 1.4.1
65 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
68 Summary: openmpi
69 License: Unkown
70 Name: %{name}
71 Version: %{version}
72 Release: %{release}
73 URL: http://www.open-mpi.org/software/ompi/v1.4/downloads
74 Source: %url/%{name}-%{version}.tar.gz
75 Prefix: %{_prefix}
76 Group: Development/Tools
79 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
81 %description
82 %{summary}
84 %prep
85 %setup -q
87 %build
88 # export WM settings in a form that GNU configure recognizes
89 [ -n "$WM_CC" ] && export CC="$WM_CC"
90 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
91 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
92 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
93 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
95 unset mpiWith
96 # enable GridEngine if it appears to be in use
97 if [ -n "$SGE_ROOT" ]
98 then
99 mpiWith="$mpiWith --with-sge"
100 else
101 mpiWith="$mpiWith --without-sge"
102 mpiWith="$mpiWith --enable-mca-no-build=ras-gridengine,pls-gridengine"
105 # Infiniband support
106 # if [ -d /usr/local/ofed -a -d /usr/local/ofed/lib64 ]
107 # then
108 # mpiWith="$mpiWith --with-openib=/usr/local/ofed"
109 # mpiWith="$mpiWith --with-openib-libdir=/usr/local/ofed/lib64"
110 # fi
112 ./configure \
113 --prefix=%{_installPrefix} \
114 --exec_prefix=%{_installPrefix} \
115 --disable-mpirun-prefix-by-default \
116 --disable-orterun-prefix-by-default \
117 --enable-shared --disable-static \
118 --disable-mpi-f77 \
119 --disable-mpi-f90 \
120 --disable-mpi-cxx \
121 --disable-mpi-profile \
122 --without-slurm \
123 $mpiWith \
126 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
127 make -j $WM_NCOMPPROCS
129 %install
130 make install DESTDIR=$RPM_BUILD_ROOT
132 # Creation of OpenFOAM specific .csh and .sh files"
134 echo ""
135 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
136 echo ""
138 # Generate package specific .sh file for OpenFOAM
140 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
141 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
142 # Load %{name}-%{version} libraries and binaries if available
143 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
145 export OPENMPI_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
147 [ -d \$OPENMPI_DIR/lib ] && _foamAddLib \$OPENMPI_DIR/lib
149 # Enable access to the package applications if present
150 [ -d \$OPENMPI_DIR/bin ] && _foamAddPath \$OPENMPI_DIR/bin
151 DOT_SH_EOF
154 # Generate package specific .csh file for OpenFOAM
156 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
157 # Load %{name}-%{version} libraries and binaries if available
158 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
159 setenv OPENMPI_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
161 if ( -e \$OPENMPI_DIR/lib ) then
162 _foamAddLib \$OPENMPI_DIR/lib
163 endif
165 if ( -e \$OPENMPI_DIR/bin ) then
166 _foamAddPath \$OPENMPI_DIR/bin
167 endif
168 DOT_CSH_EOF
170 #finally, generate a .tgz file for systems where using rpm for installing packages
171 # as a non-root user might be a problem.
172 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
175 %clean
176 rm -rf %{buildroot}
178 %files
179 %defattr(-,root,root)
180 %{_installPrefix}/*