1 #------------------------------------------------------------------------------
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
5 # \\ / A nd | Copyright held by original author
7 #------------------------------------------------------------------------------
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
26 # RPM spec file for ParMGridGen-1.0
29 # RPM spec file for creating a relocatable RPM
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package
%{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath
%{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in thi file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
62 %define _prefix
%{_WM_THIRD_PARTY_DIR}
64 %define name ParMGridGen
65 %define release
%{_WM_OPTIONS}
68 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
76 URL: http
://www.mgnet.org
/mgnet
/Codes
/parmgridgen
77 Source: %url/%{name}-%{version}.tar.gz
79 Group: Development
/Tools
80 Patch0: ParMGridGen
-1.0.patch_darwin
81 Patch1: ParMGridGen
-1.0.patch
83 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
98 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
99 make -j $WM_NCOMPPROCS
102 # Manual installation
103 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/include
/Lib
104 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/include
/IMlib
105 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/lib
107 cp .
/MGridGen
/Lib
/*.h $RPM_BUILD_ROOT
/%{_installPrefix}/include
/Lib
108 cp .
/MGridGen
/IMlib
/*.h $RPM_BUILD_ROOT
/%{_installPrefix}/include
/IMlib
110 cp .
/MGridGen
/IMlib
/libIMlib.
* $RPM_BUILD_ROOT
/%{_installPrefix}/lib
111 cp .
/MGridGen
/Lib
/libMGridGen.
* $RPM_BUILD_ROOT
/%{_installPrefix}/lib
113 # Creation of OpenFOAM specific .csh and .sh files"
116 echo "Generating OpenFOAM specific .csh and .sh files
for the package
%{name}-%{version}"
119 # Generate package specific .sh file for OpenFOAM
121 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
122 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
123 # Load %{name}-%{version} libraries and binaries if available
124 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
126 export PARMGRIDGEN_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
127 export PARMGRIDGEN_BIN_DIR
=\$PARMGRIDGEN_DIR
/bin
128 export PARMGRIDGEN_LIB_DIR
=\$PARMGRIDGEN_DIR
/lib
129 export PARMGRIDGEN_INCLUDE_DIR
=\$PARMGRIDGEN_DIR
/include
131 # Enable access to the runtime package applications and libraries
132 [ -d \$PARMGRIDGEN_BIN_DIR
] && _foamAddPath \$PARMGRIDGEN_BIN_DIR
133 [ -d \$PARMGRIDGEN_LIB_DIR
] && _foamAddLib \$PARMGRIDGEN_LIB_DIR
137 # Generate package specific .csh file for OpenFOAM
139 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
140 # Load %{name}-%{version} libraries and binaries if available
141 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
142 setenv PARMGRIDGEN_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
143 setenv PARMGRIDGEN_BIN_DIR \$PARMGRIDGEN_DIR
/bin
144 setenv PARMGRIDGEN_LIB_DIR \$PARMGRIDGEN_DIR
/lib
145 setenv PARMGRIDGEN_INCLUDE_DIR \$PARMGRIDGEN_DIR
/include
147 if ( -e \$PARMGRIDGEN_BIN_DIR
) then
148 _foamAddPath \$PARMGRIDGEN_BIN_DIR
151 if ( -e \$PARMGRIDGEN_LIB_DIR
) then
152 _foamAddLib \$PARMGRIDGEN_LIB_DIR
156 #finally, generate a .tgz file for systems where using rpm for installing packages
157 # as a non-root user might be a problem.
158 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
165 %defattr(-,root
,root
)
166 %{_installPrefix}/include
167 %{_installPrefix}/lib
/*
168 %{_installPrefix}/etc
/*