Upstream tarball 20080806
[amule.git] / debian / rules
blobf0a02b418f796cdf5b430fc7e4a136c0f0be504d
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # This file was originally written by Vollstrecker
5 # Uncomment this to turn on verbose mode.
6 export DH_VERBOSE=1
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14 CFLAGS = -Wall -g
16 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17 CFLAGS += -O0
18 else
19 CFLAGS += -O2
20 endif
22 #Here are the packages that can't be compiled separate now
23 general_pkgs = "amule-common"\
24 "amule-skin-gnome"\
25 "amule-skin-kde4"\
26 "amule-skin-tango"\
27 "amule-skin-xfce"\
28 "amule-theme-default"\
29 "amule-theme-php-default"\
30 "amule-theme-chicane"
32 # First, get the targets from commandline
33 flags = ${MAKECMDGOALS}
35 #First we have to find out, if we are called from dpkg-buildpackage
37 ifeq ("binary", "$(findstring binary, $(flags))")
39 WXCAS = --enable-wxcas
40 CAS = --enable-cas
41 WEBSERVER = --enable-webserver
42 REMOTEGUI = --enable-amule-gui
43 DAEMON = --enable-amule-daemon
44 ALCC = --enable-alcc
45 ALC = --enable-alc
46 AMULECMD = --enable-amulecmd
47 DEBUGGING = --enable-debug --disable-optimize --disable-profile
48 LANGFLAG = --with-language=all
50 else ifeq ("clean", "$(findstring clean, $(flags))")
52 WXCAS = --enable-wxcas
53 CAS = --enable-cas
54 WEBSERVER = --enable-webserver
55 REMOTEGUI = --enable-amule-gui
56 DAEMON = --enable-amule-daemon
57 ALCC = --enable-alcc
58 ALC = --enable-alc
59 AMULECMD = --enable-amulecmd
60 DEBUGGING = --enable-debug --disable-optimize --disable-profile
61 LANGFLAG = --with-language=all
63 else ifeq ("build", "$(findstring build, $(flags))")
65 WXCAS = --enable-wxcas
66 CAS = --enable-cas
67 WEBSERVER = --enable-webserver
68 REMOTEGUI = --enable-amule-gui
69 DAEMON = --enable-amule-daemon
70 ALCC = --enable-alcc
71 ALC = --enable-alc
72 AMULECMD = --enable-amulecmd
73 DEBUGGING = --enable-debug --disable-optimize --disable-profile
74 LANGFLAG = --with-language=all
76 else
77 #Now we have to check what packages are build to configure only them
79 #We have to filter the right targets (wo_ means without)
80 wo_wxcas = $(subst wxcas, , ${flags})
81 wo_alcc = $(subst alcc, , ${flags})
82 wo_amule_utils_gui = $(subst amule-utils-gui, ,${flags})
83 wo_all_other_amules = $(subst amulecmd, ,$(subst amule-utils-gui, ,$(subst amule-utils, ,${flags})))
84 LANGUAGE := en_GB
86 ifeq ("wxcas", "$(findstring wxcas, $(flags))")
87 WXCAS = --enable-wxcas
88 endif
90 ifeq ("cas", "$(findstring cas, $(wo_wxcas))")
91 CAS = --enable-cas
92 endif
94 ifeq ("webserver", "$(findstring webserver, $(flags))")
95 WEBSERVER = --enable-webserver
96 endif
98 ifeq ("remotegui", "$(findstring remotegui, $(flags))")
99 REMOTEGUI = --enable-amule-gui
100 endif
102 ifeq ("daemon", "$(findstring daemon, $(flags))")
103 DAEMON = --enable-amule-daemon
104 endif
106 ifeq ("alcc", "$(findstring alcc, $(flags))")
107 ALCC = --enable-alcc
108 endif
110 ifeq ("alc", "$(findstring alc, $(wo_alcc))")
111 ALC = --enable-alc
112 endif
114 ifeq ("amulecmd", "$(findstring amulecmd, $(flags))")
115 AMULECMD = --enable-amulecmd
116 endif
118 ifneq ("amule", "$(findstring amule, $(wo_all_other_amules))")
119 AMULE = --disable-monolithic
120 endif
122 ifneq ("ed2k", "$(findstring ed2k, $(flags))")
123 ED2K = --disable-ed2k
124 endif
126 ifneq ("xas", "$(findstring xas, $(flags))")
127 XAS = --disable-xas
128 endif
130 #Now find out if a Metapackage should be build
131 ifeq ("amule-utils-gui", "$(findstring amule-utils-gui, $(flags))")
132 ALC = --enable-alc
133 REMOTEGUI = --enable-amule-gui
134 WXCAS = --enable-wxcas
135 endif
137 ifeq ("amule-utils", "$(findstring amule-utils, $(wo_amule_utils_gui))")
138 ALCC = --enable-alcc
139 AMULECMD = --enable-amulecmd
140 CAS = --enable-cas
141 endif
143 #Find this whole i18n stuff
144 ifneq ("i18n-en-only", "$(findstring i18n-en-only, $(flags))")
146 ifeq ("i18n-ar", "$(findstring i18n-ar, $(flags))")
147 LANGUAGE := $(LANGUAGE),ar
148 endif
150 ifeq ("i18n-bg", "$(findstring i18n-bg, $(flags))")
151 LANGUAGE := $(LANGUAGE),bg
152 endif
154 ifeq ("i18n-ca", "$(findstring i18n-ca, $(flags))")
155 LANGUAGE := $(LANGUAGE),ca
156 endif
158 ifeq ("i18n-da", "$(findstring i18n-da, $(flags))")
159 LANGUAGE := $(LANGUAGE),da
160 endif
162 ifeq ("i18n-de", "$(findstring i18n-de, $(flags))")
163 LANGUAGE := $(LANGUAGE),de
164 endif
166 ifeq ("i18n-es", "$(findstring i18n-es, $(flags))")
167 LANGUAGE := $(LANGUAGE),es
168 endif
170 ifeq ("i18n-et-ee", "$(findstring i18n-et-ee, $(flags))")
171 LANGUAGE := $(LANGUAGE),et_EE
172 endif
174 ifeq ("i18n-eu", "$(findstring i18n-eu, $(flags))")
175 LANGUAGE := $(LANGUAGE),eu
176 endif
178 ifeq ("i18n-fi", "$(findstring i18n-fi, $(flags))")
179 LANGUAGE := $(LANGUAGE),fi
180 endif
182 ifeq ("i18n-fr", "$(findstring i18n-fr, $(flags))")
183 LANGUAGE := $(LANGUAGE),fr
184 endif
186 ifeq ("i18n-gl", "$(findstring i18n-gl, $(flags))")
187 LANGUAGE := $(LANGUAGE),gl
188 endif
190 ifeq ("i18n-hr", "$(findstring i18n-hr, $(flags))")
191 LANGUAGE := $(LANGUAGE),hr
192 endif
194 ifeq ("i18n-hu", "$(findstring i18n-hu, $(flags))")
195 LANGUAGE := $(LANGUAGE),hu
196 endif
198 ifeq ("i18n-it", "$(findstring i18n-it, $(flags))")
199 LANGUAGE := $(LANGUAGE),it
200 endif
202 ifeq ("i18n-it-ch", "$(findstring i18n-it-ch, $(flags))")
203 LANGUAGE := $(LANGUAGE),it_CH
204 endif
206 ifeq ("i18n-ko-kr", "$(findstring i18n-ko-kr, $(flags))")
207 LANGUAGE := $(LANGUAGE),ko_KR
208 endif
210 ifeq ("i18n-lt", "$(findstring i18n-lt, $(flags))")
211 LANGUAGE := $(LANGUAGE),lt
212 endif
214 ifeq ("i18n-nl", "$(findstring i18n-nl, $(flags))")
215 LANGUAGE := $(LANGUAGE),hl
216 endif
218 ifeq ("i18n-nn", "$(findstring i18n-nn, $(flags))")
219 LANGUAGE := $(LANGUAGE),nn
220 endif
222 ifeq ("i18n-pl", "$(findstring i18n-pl, $(flags))")
223 LANGUAGE := $(LANGUAGE),pl
224 endif
226 ifeq ("i18n-pt-br", "$(findstring i18n-pt-br, $(flags))")
227 LANGUAGE := $(LANGUAGE),pt_BR
228 endif
230 ifeq ("i18n-pt-pt", "$(findstring i18n-pt-pt, $(flags))")
231 LANGUAGE := $(LANGUAGE),pt_PT
232 endif
234 ifeq ("i18n-ru", "$(findstring i18n-ru, $(flags))")
235 LANGUAGE := $(LANGUAGE),ru
236 endif
238 ifeq ("i18n-sl", "$(findstring i18n-sl, $(flags))")
239 LANGUAGE := $(LANGUAGE),sl
240 endif
242 ifeq ("i18n-sv", "$(findstring i18n-sv, $(flags))")
243 LANGUAGE := $(LANGUAGE),sv
244 endif
246 ifeq ("i18n-tr", "$(findstring i18n-tr, $(flags))")
247 LANGUAGE := $(LANGUAGE),tr
248 endif
250 ifeq ("i18n-zh-cn", "$(findstring i18n-zh-cn, $(flags))")
251 LANGUAGE := $(LANGUAGE),zh_CN
252 endif
254 ifeq ("i18n-zh-tw", "$(findstring i18n-zh-tw, $(flags))")
255 LANGUAGE := $(LANGUAGE),zh_TW
256 endif
258 ifeq ($(LANGUAGE),en_GB)
259 LANGUAGE = all
260 endif
262 endif
264 LANGFLAG = --with-language=$(LANGUAGE)
266 #And at Last, find out if we compile a debug-package or not.
267 ifeq ("dbg", "$(findstring dbg, $(flags))")
268 DEBUGGING = --enable-debug --disable-optimize --disable-profile
269 else
270 DEBUGGING = --disable-debug --enable-optimize --disable-profile
271 endif
272 endif
274 #Before we start, I want to introduce two sequences for building the packages
275 #I define two, so I can put the commands for the *-dbg packages between them
276 define stage1
277 dh_testdir -p${pkg}
278 dh_testroot -p${pkg}
279 dh_installdirs -p${pkg}
280 dh_installchangelogs docs/Changelog -p${pkg}
281 dh_installdocs -p${pkg}
282 dh_install -Xlicense.txt -p${pkg}
283 dh_installmenu -p${pkg}
284 dh_installdebconf -p${pkg}
285 dh_installman -p${pkg}
286 dh_link -p${pkg}
287 install -D --mode=644 debian/${pkg}.override debian/${pkg}/usr/share/lintian/overrides/${pkg}
288 touch $@
289 endef
291 define stage2
292 dh_compress -X.pl -p${pkg}
293 dh_perl -p${pkg}
294 dh_makeshlibs -p${pkg}
295 dh_installdeb -p${pkg}
296 dh_shlibdeps -p${pkg}
297 dh_gencontrol -p${pkg}
298 dh_md5sums -p${pkg}
299 dh_fixperms -p${pkg}
300 dh_builddeb -p${pkg}
301 touch $@
302 endef
304 #Now we configure this whole thing
305 config.status: configure
306 dh_testdir
307 CFLAGS="$(CFLAGS)" ./configure\
308 --host=$(DEB_HOST_GNU_TYPE)\
309 --build=$(DEB_BUILD_GNU_TYPE)\
310 --prefix=/usr\
311 --mandir=\$${prefix}/share/man\
312 --infodir=\$${prefix}/share/info\
313 --with-ccache\
314 --enable-geoip\
315 ${AMULECMD}\
316 ${DEBUGGING}\
317 ${WEBSERVER}\
318 ${CAS}\
319 ${WXCAS}\
320 ${ALC}\
321 ${ALCC}\
322 ${REMOTEGUI}\
323 ${DAEMON}\
324 ${AMULE}\
325 ${ED2K}\
326 $(LANGFLAG)\
327 $(XAS)
330 #And here is the well known clean target
331 clean:
332 dh_testdir
333 dh_testroot
334 dh_clean
335 rm -f alc
336 rm -f alc-dbg
337 rm -f alcc
338 rm -f alcc-dbg
339 rm -f amule
340 rm -f amule-alc-dbg
341 rm -f amule-alc-stage1
342 rm -f amule-alc-stage2
343 rm -f amule-alcc-dbg
344 rm -f amule-alcc-stage1
345 rm -f amule-alcc-stage2
346 rm -f amule-cas-dbg
347 rm -f amule-cas-stage1
348 rm -f amule-cas-stage2
349 rm -f amule-cmd-dbg
350 rm -f amule-cmd-stage1
351 rm -f amule-cmd-stage2
352 rm -f amule-common
353 rm -f amule-daemon-dbg
354 rm -f amule-daemon-stage1
355 rm -f amule-daemon-stage2
356 rm -f amule-dbg
357 rm -f amule-ed2k-dbg
358 rm -f amule-ed2k-stage1
359 rm -f amule-ed2k-stage2
360 rm -f amule-remote-gui-dbg
361 rm -f amule-remote-gui-stage1
362 rm -f amule-remote-gui-stage2
363 rm -f amule-stage1
364 rm -f amule-stage2
365 rm -f amule-utils
366 rm -f amule-utils-gui
367 rm -f amule-wxcas-dbg
368 rm -f amule-wxcas-stage1
369 rm -f amule-wxcas-stage2
370 rm -f amulecmd
371 rm -f amulecmd-dbg
372 rm -f amuleweb-stage1
373 rm -f amuleweb-stage2
374 rm -f amuleweb-dbg
375 rm -f build-stamp
376 rm -f cas
377 rm -f cas-dbg
378 rm -f compile
379 rm -f daemon
380 rm -f daemon-dbg
381 rm -f ed2k
382 rm -f ed2k-dbg
383 rm -f i18n-ar
384 rm -f i18n-bg
385 rm -f i18n-ca
386 rm -f i18n-da
387 rm -f i18n-de
388 rm -f i18n-en-gb
389 rm -f i18n-es
390 rm -f i18n-et-ee
391 rm -f i18n-eu
392 rm -f i18n-fi
393 rm -f i18n-fr
394 rm -f i18n-gl
395 rm -f i18n-hr
396 rm -f i18n-hu
397 rm -f i18n-it
398 rm -f i18n-it-ch
399 rm -f i18n-ko-kr
400 rm -f i18n-lt
401 rm -f i18n-nl
402 rm -f i18n-nn
403 rm -f i18n-pl
404 rm -f i18n-pt-br
405 rm -f i18n-pt-pt
406 rm -f i18n-ru
407 rm -f i18n-sl
408 rm -f i18n-sv
409 rm -f i18n-tr
410 rm -f i18n-zh-cn
411 rm -f i18n-zh-tw
412 rm -f remotegui
413 rm -f remotegui-dbg
414 rm -f webserver
415 rm -f webserver-dbg
416 rm -f wxcas
417 rm -f wxcas-dbg
418 rm -f xas
420 [ ! -f Makefile ] || $(MAKE) distclean
422 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
423 cp -f /usr/share/misc/config.sub config.sub
424 endif
425 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
426 cp -f /usr/share/misc/config.guess config.guess
427 endif
429 rm -f debian/files
430 dh_clean -k
432 #Some generic targets to check the build process
433 build: build-stamp
435 build-stamp: config.status
436 dh_testdir
438 # Add here commands to compile the package.
439 $(MAKE)
441 touch build-stamp
443 #Now we install the packages all together to the tmp-dir inside of debian/
444 install: build
445 dh_testdir
446 dh_testroot
447 dh_clean -a -k
448 dh_installdirs
450 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
452 #Now first build the packages that are compiled and installed on every build
453 amule-common: install
455 for pkg in $(general_pkgs); do \
456 dh_testdir -p$$pkg; \
457 dh_testroot -p$$pkg; \
458 dh_installdirs -p$$pkg; \
459 dh_installchangelogs docs/Changelog -p$$pkg; \
460 dh_installdocs -p$$pkg; \
461 dh_install -Xlicense.txt -p$$pkg; \
462 dh_installmenu -p$$pkg; \
463 dh_installdebconf -p$$pkg; \
464 dh_installman -p$$pkg; \
465 dh_link -p$$pkg; \
466 install -D --mode=644 debian/$$pkg.override debian/$$pkg/usr/share/lintian/overrides/$$pkg; \
467 dh_compress -X.pl -p$$pkg; \
468 dh_perl -p$$pkg; \
469 dh_makeshlibs -p$$pkg; \
470 dh_installdeb -p$$pkg; \
471 dh_shlibdeps -p$$pkg; \
472 dh_gencontrol -p$$pkg; \
473 dh_md5sums -p$$pkg; \
474 dh_fixperms -p$$pkg; \
475 dh_builddeb -p$$pkg; \
476 done
477 touch amule-common
479 amule-stage1: pkg=amule
480 amule-stage1: amule-common
481 ${stage1}
483 amule-stage2: pkg=amule
484 amule-stage2: amule-stage1
485 ${stage2}
487 amule-ed2k-stage1: pkg=amule-ed2k
488 amule-ed2k-stage1: amule-common
489 ${stage1}
491 amule-ed2k-stage2: pkg=amule-ed2k
492 amule-ed2k-stage2: amule-ed2k-stage1
493 ${stage2}
495 amule-xas-stage1: pkg=amule-xas
496 amule-xas-stage1: amule-common
497 ${stage1}
499 amule-xas-stage2: pkg=amule-xas
500 amule-xas-stage2: amule-xas-stage1
501 ${stage2}
503 amule-cas-stage1: pkg=amule-cas
504 amule-cas-stage1: amule-common
505 ${stage1}
507 amule-cas-stage2: pkg=amule-cas
508 amule-cas-stage2: amule-cas-stage1
509 ${stage2}
511 amule-wxcas-stage1: pkg=amule-wxcas
512 amule-wxcas-stage1: amule-common
513 ${stage1}
515 amule-wxcas-stage2: pkg=amule-wxcas
516 amule-wxcas-stage2: amule-wxcas-stage1
517 ${stage2}
519 amuleweb-stage1: pkg=amuleweb
520 amuleweb-stage1: amule-common
521 ${stage1}
523 amuleweb-stage2: pkg=amuleweb
524 amuleweb-stage2: amuleweb-stage1
525 ${stage2}
527 amule-remote-gui-stage1: pkg=amule-remote-gui
528 amule-remote-gui-stage1: amule-common
529 ${stage1}
531 amule-remote-gui-stage2: pkg=amule-remote-gui
532 amule-remote-gui-stage2: amule-remote-gui-stage1
533 ${stage2}
535 amule-daemon-stage1: pkg=amule-daemon
536 amule-daemon-stage1: amule-common
537 ${stage1}
539 amule-daemon-stage2: pkg=amule-daemon
540 amule-daemon-stage2: amule-daemon-stage1
541 ${stage2}
543 amule-alc-stage1: pkg=amule-alc
544 amule-alc-stage1: amule-common
545 ${stage1}
547 amule-alc-stage2: pkg=amule-alc
548 amule-alc-stage2: amule-alc-stage1
549 ${stage2}
551 amule-alcc-stage1: pkg=amule-alcc
552 amule-alcc-stage1: amule-common
553 ${stage1}
555 amule-alcc-stage2: pkg=amule-alcc
556 amule-alcc-stage2: amule-alcc-stage1
557 ${stage2}
559 amule-cmd-stage1: pkg=amule-cmd
560 amule-cmd-stage1: amule-common
561 ${stage1}
563 amule-cmd-stage2: pkg=amule-cmd
564 amule-cmd-stage2: amule-alcc-stage1
565 ${stage2}
568 amule-ed2k-dbg: pkg=amule-ed2k-dbg
569 amule-ed2k-dbg: amule-ed2k-stage1
570 ${stage1}
571 dh_strip -pamule-ed2k --dbg-package=amule-ed2k-dbg
572 ${stage2}
574 amule-cas-dbg: pkg=amule-cas-dbg
575 amule-cas-dbg: amule-cas-stage1
576 ${stage1}
577 dh_strip -pamule-cas --dbg-package=amule-cas-dbg
578 ${stage2}
580 amule-wxcas-dbg: pkg=amule-wxcas-dbg
581 amule-wxcas-dbg: amule-wxcas-stage1
582 ${stage1}
583 dh_strip -pamule-wxcas --dbg-package=amule-wxcas-dbg
584 ${stage2}
586 amuleweb-dbg: pkg=amuleweb-dbg
587 amuleweb-dbg: amuleweb-stage1
588 ${stage1}
589 dh_strip -pamuleweb --dbg-package=amuleweb-dbg
590 ${stage2}
592 amule-remote-gui-dbg: pkg=amule-remote-gui-dbg
593 amule-remote-gui-dbg: amule-remote-gui-stage1
594 ${stage1}
595 dh_strip -pamule-remote-gui --dbg-package=amule-remote-gui-dbg
596 ${stage2}
598 amule-daemon-dbg: pkg=amule-daemon-dbg
599 amule-daemon-dbg: amule-daemon-stage1
600 ${stage1}
601 dh_strip -pamule-daemon --dbg-package=amule-daemon-dbg
602 ${stage2}
604 amule-alc-dbg: pkg=amule-alc-dbg
605 amule-alc-dbg: amule-alc-stage1
606 ${stage1}
607 dh_strip -pamule-alc --dbg-package=amule-alc-dbg
608 ${stage2}
610 amule-alcc-dbg: pkg=amule-alcc-dbg
611 amule-alcc-dbg: amule-alcc-stage1
612 ${stage1}
613 dh_strip -pamule-alcc --dbg-package=amule-alcc-dbg
614 ${stage2}
616 amule-cmd-dbg: pkg=amule-cmd-dbg
617 amule-cmd-dbg: amule-cmd-stage1
618 ${stage1}
619 dh_strip -pamule-cmd --dbg-package=amule-cmd-dbg
620 ${stage2}
622 #Now just the targets to map the Commandline Name to the package names
623 amule: amule-stage2
624 touch amule
626 ed2k: amule-ed2k-stage2
627 touch ed2k
629 cas: amule-cas-stage2
630 touch cas
632 wxcas: amule-wxcas-stage2
633 touch wxcas
635 webserver: amuleweb-stage2
636 touch webserver
638 remotegui: amule-remote-gui-stage2
639 touch remotegui
641 daemon: amule-daemon-stage2
642 touch daemon
644 alc: amule-alc-stage2
645 touch alc
647 alcc: amule-alcc-stage2
648 touch alcc
650 amulecmd: amule-cmd-stage2
651 touch amulecmd
653 xas: amule-xas-stage2
654 touch xas
656 ed2k-dbg: amule-ed2k-dbg
657 touch ed2k-dbg
659 cas-dbg: amule-cas-dbg
660 touch cas-dbg
662 wxcas-dbg: amule-wxcas-dbg
663 touch wxcas-dbg
665 webserver-dbg: amuleweb-dbg
666 touch webserver-dbg
668 remotegui-dbg: amule-remote-gui-dbg
669 touch remotegui-dbg
671 daemon-dbg: amule-daemon-dbg
672 touch daemon-dbg
674 alc-dbg: amule-alc-dbg
675 touch alc-dbg
677 alcc-dbg: amule-alcc-dbg
678 touch alcc-dbg
680 amulecmd-dbg: amule-cmd-dbg
681 touch amulecmd-dbg
683 amule-dbg: pkg=amule-dbg
684 amule-dbg: amule-stage1
685 ${stage1}
686 dh_strip -pamule --dbg-package=amule-dbg
687 ${stage2}
689 #Her come the Targets for the langauge packages
690 i18n-ar: pkg=amule-i18n-ar
691 i18n-ar: amule-common
692 ${stage1}
693 ${stage2}
695 i18n-bg: pkg=amule-i18n-bg
696 i18n-bg: amule-common
697 ${stage1}
698 ${stage2}
700 i18n-ca: pkg=amule-i18n-ca
701 i18n-ca: amule-common
702 ${stage1}
703 ${stage2}
705 i18n-da: pkg=amule-i18n-da
706 i18n-da: amule-common
707 ${stage1}
708 ${stage2}
710 i18n-de: pkg=amule-i18n-de
711 i18n-de: amule-common
712 ${stage1}
713 ${stage2}
715 i18n-en-gb: pkg=amule-i18n-en-gb
716 i18n-en-gb: amule-common
717 ${stage1}
718 ${stage2}
720 i18n-es: pkg=amule-i18n-es
721 i18n-es: amule-common
722 ${stage1}
723 ${stage2}
725 i18n-et-ee: pkg=amule-i18n-et-ee
726 i18n-et-ee: amule-common
727 ${stage1}
728 ${stage2}
730 i18n-eu: pkg=amule-i18n-eu
731 i18n-eu: amule-common
732 ${stage1}
733 ${stage2}
735 i18n-fi: pkg=amule-i18n-fi
736 i18n-fi: amule-common
737 ${stage1}
738 ${stage2}
740 i18n-fr: pkg=amule-i18n-fr
741 i18n-fr: amule-common
742 ${stage1}
743 ${stage2}
745 i18n-gl: pkg=amule-i18n-gl
746 i18n-gl: amule-common
747 ${stage1}
748 ${stage2}
750 i18n-hr: pkg=amule-i18n-hr
751 i18n-hr: amule-common
752 ${stage1}
753 ${stage2}
755 i18n-hu: pkg=amule-i18n-hu
756 i18n-hu: amule-common
757 ${stage1}
758 ${stage2}
760 i18n-it-ch: pkg=amule-i18n-it-ch
761 i18n-it-ch: amule-common
762 ${stage1}
763 ${stage2}
765 i18n-it: pkg=amule-i18n-it
766 i18n-it: amule-common
767 ${stage1}
768 ${stage2}
770 i18n-ko-kr: pkg=amule-i18n-ko-kr
771 i18n-ko-kr: amule-common
772 ${stage1}
773 ${stage2}
775 i18n-lt: pkg=amule-i18n-lt
776 i18n-lt: amule-common
777 ${stage1}
778 ${stage2}
780 i18n-nn: pkg=amule-i18n-nn
781 i18n-nn: amule-common
782 ${stage1}
783 ${stage2}
785 i18n-nl: pkg=amule-i18n-nl
786 i18n-nl: amule-common
787 ${stage1}
788 ${stage2}
790 i18n-pl: pkg=amule-i18n-pl
791 i18n-pl: amule-common
792 ${stage1}
793 ${stage2}
795 i18n-pt-br: pkg=amule-i18n-pt-br
796 i18n-pt-br: amule-common
797 ${stage1}
798 ${stage2}
800 i18n-pt-pt: pkg=amule-i18n-pt-pt
801 i18n-pt-pt: amule-common
802 ${stage1}
803 ${stage2}
805 i18n-ru: pkg=amule-i18n-ru
806 i18n-ru: amule-common
807 ${stage1}
808 ${stage2}
810 i18n-sl: pkg=amule-i18n-sl
811 i18n-sl: amule-common
812 ${stage1}
813 ${stage2}
815 i18n-sv: pkg=amule-i18n-sv
816 i18n-sv: amule-common
817 ${stage1}
818 ${stage2}
820 i18n-tr: pkg=amule-i18n-tr
821 i18n-tr: amule-common
822 ${stage1}
823 ${stage2}
825 i18n-zh-cn: pkg=amule-i18n-zh-cn
826 i18n-zh-cn: amule-common
827 ${stage1}
828 ${stage2}
830 i18n-zh-tw: pkg=amule-i18n-zh-tw
831 i18n-zh-tw: amule-common
832 ${stage1}
833 ${stage2}
835 #They are just metapackages
836 amule-utils: pkg=amule-utils
837 amule-utils: alcc amulecmd cas
838 ${stage1}
839 ${stage2}
841 amule-utils-gui: pkg=amule-utils-gui
842 amule-utils-gui: alc remotegui wxcas
843 ${stage1}
844 ${stage2}
846 #These Two are empty (Space after Semicolon)
847 debug-packages: amule-dbg ed2k-dbg cas-dbg wxcas-dbg webserver-dbg remotegui-dbg daemon-dbg alc-dbg alcc-dbg amulecmd-dbg ;
848 normal-packages: amule-utils amule-utils-gui amule ed2k webserver daemon ;
850 language-packages: i18n-ar i18n-bg i18n-ca i18n-da i18n-de i18n-en-gb i18n-es i18n-et-ee i18n-eu i18n-fi i18n-fr i18n-gl i18n-hr i18n-hu i18n-it-ch i18n-it i18n-ko-kr i18n-lt i18n-nn i18n-nl i18n-pl i18n-pt-br i18n-pt-pt i18n-ru i18n-sl i18n-sv i18n-tr i18n-zh-cn i18n-zh-tw ;
852 i18n-en-only: ;
854 #If we build from a svn checkout, we need to generate configure
855 configure:
856 ./autogen.sh
858 #Now the targets for dpkg-buildpackage
859 binary-indep: build install
861 binary-arch: debug-packages normal-packages language-packages
863 binary: binary-indep binary-arch
865 help:
866 cat README.Debian-Packages
868 .DEFAULT_GOAL = help
869 .PHONY: build clean binary-indep binary-arch binary install debug-packages normal-packages amule-utils-gui amule-utils i18n-only language-packages