archrelease: copy trunk to community-any
[arch-community.git] / python-docs / trunk / PKGBUILD
blob83d75aa04efe7fea61e17e7575bc80cb688c0bf1
1 # Maintainer: Morten Linderud <foxboron@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: Rohan Dhruva (rohandhruva at gmail dot com)
5 pkgname=python-docs
6 pkgver=3.11.3
7 pkgrel=1
8 pkgdesc="Set of HTML documentation for python"
9 arch=('any')
10 url="https://docs.python.org/py3k/"
11 license=('GPL')
12 options=('docs')
13 source=(https://sources.archlinux.org/other/community/python-docs/python-$pkgver-docs-html.tar.bz2)
14 sha256sums=('8af1ff8163810b328a0f9ce0e88fc430b0fe6a54a99dfd3265dded3bf547ccb9')
16 package() {
17   mkdir -p "$pkgdir"/usr/share/doc/python/html
18   cp -rf "$srcdir"/python-$pkgver-docs-html/* "$pkgdir"/usr/share/doc/python/html/
19   find "$pkgdir"/usr/share/doc/python/html/ -type f -exec chmod 0644 {} \;
20   find "$pkgdir"/usr/share/doc/python/html/ -type d -exec chmod 0755 {} \;
21   install -dm0755 "$pkgdir"/etc/profile.d
22   echo "export PYTHONDOCS=/usr/share/doc/python/html/library" >"$pkgdir"/etc/profile.d/$pkgname.sh
23   echo "setenv PYTHONDOCS /usr/share/doc/python/html/library" >"$pkgdir"/etc/profile.d/$pkgname.csh