archrelease: copy trunk to community-any
[arch-community.git] / python-jaraco.context / trunk / PKGBUILD
blob68c9fd474cd23485dfa632004faf9726298f3c4b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-jaraco.context
4 pkgver=4.3.0
5 _commit=0e0ae08919b984e3c7cffdb2106e437d0d0891c8
6 pkgrel=3
7 pkgdesc="Context managers by jaraco"
8 url="https://github.com/jaraco/jaraco.context"
9 license=('MIT')
10 arch=('any')
11 depends=('python')
12 makedepends=('git' 'python-setuptools-scm' 'python-build' 'python-installer' 'python-wheel')
13 checkdepends=('python-pytest')
14 source=("git+https://github.com/jaraco/jaraco.context.git#commit=$_commit")
15 sha512sums=('SKIP')
17 build() {
18   cd jaraco.context
19   python -m build -wn
22 check() {
23   cd jaraco.context
24   python -m pytest
27 package() {
28   cd jaraco.context
29   python -m installer -d "$pkgdir" dist/*.whl
30   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/