1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
5 _commit=4a9e0d4e23001ae97820af186a9b40df371ad5df
7 pkgdesc='MRI+JRuby compatible command output capturing'
9 url='https://github.com/guard/shellany'
12 makedepends=(git ruby-nenv ruby-rake ruby-rspec)
14 source=(git+https://github.com/guard/shellany.git#commit=$_commit)
19 sed -i '1i require "shellany"' spec/shellany_spec.rb
23 local _gemdir="$(gem env gemdir)"
25 gem build shellany.gemspec
29 --ignore-dependencies \
31 --install-dir "tmp_install/$_gemdir" \
32 --bindir "tmp_install/usr/bin" \
34 find "tmp_install/$_gemdir/gems/" \
41 -iname "gem.build_complete" -o \
45 rm -r tmp_install/$_gemdir/cache
49 local _gemdir="$(gem env gemdir)"
51 GEM_HOME="tmp_install/$_gemdir" rake
56 cp -a tmp_install/* "$pkgdir"/
57 install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname/