1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Helper library for geocoding services"
8 url="https://gitlab.gnome.org/GNOME/geocode-glib"
11 depends=(glib2 json-glib libsoup)
12 makedepends=(gobject-introspection git gtk-doc meson)
13 provides=(libgeocode-glib.so)
15 _commit=210abe69d68e38947106f4680631c369b0c23189 # tags/3.26.4^0
16 source=("git+https://gitlab.gnome.org/GNOME/geocode-glib.git#commit=$_commit")
21 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 arch-meson $pkgname build -D enable-installed-tests=false
30 meson compile -C build
34 # Tests need locales we don't have: en_GB.UTF-8 fr_FR.UTF-8 cs_CZ.UTF-8
35 meson test -C build --print-errorlogs || :
39 meson install -C build --destdir "$pkgdir"