archrelease: copy trunk to extra-x86_64
[arch-packages.git] / geocode-glib / trunk / PKGBUILD
blobd841e04df0d38b665eda906b84f0c06b8c847fc5
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=geocode-glib
5 pkgver=3.26.4
6 pkgrel=1
7 pkgdesc="Helper library for geocoding services"
8 url="https://gitlab.gnome.org/GNOME/geocode-glib"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(glib2 json-glib libsoup)
12 makedepends=(gobject-introspection git gtk-doc meson)
13 provides=(libgeocode-glib.so)
14 options=(debug)
15 _commit=210abe69d68e38947106f4680631c369b0c23189  # tags/3.26.4^0
16 source=("git+https://gitlab.gnome.org/GNOME/geocode-glib.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build -D enable-installed-tests=false
30   meson compile -C build
33 check() {
34   # Tests need locales we don't have: en_GB.UTF-8 fr_FR.UTF-8 cs_CZ.UTF-8
35   meson test -C build --print-errorlogs || :
38 package() {
39   meson install -C build --destdir "$pkgdir"