archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libwnck3 / trunk / PKGBUILD
blobcaca7f109764259a9064651c7eae750d63f75096
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=libwnck3
5 pkgver=40.1
6 pkgrel=1
7 pkgdesc="Library to manage X windows and workspaces (via pagers, tasklists, etc.)"
8 url="https://gitlab.gnome.org/GNOME/libwnck"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(gtk3 startup-notification libxres)
12 makedepends=(gobject-introspection gtk-doc git meson)
13 _commit=7fab141ba787cecb576b732c9182b006453d82f4  # tags/40.1^0
14 source=("git+https://gitlab.gnome.org/GNOME/libwnck.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd libwnck
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd libwnck
26 build() {
27   arch-meson libwnck build -D gtk_doc=true
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 et: