archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xfce4-xkb-plugin / trunk / PKGBUILD
blob452f8fdc9d6ec2575e6109c0573c8df053b65a41
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: AndyRTR <andyrtr@archlinux.org>
3 # Contributor: Tobias Kieslich <tobias (at) archlinux.org>
5 pkgname=xfce4-xkb-plugin
6 pkgver=0.8.3
7 pkgrel=1
8 pkgdesc="Plugin to switch keyboard layouts for the Xfce4 panel"
9 arch=('x86_64')
10 url="https://docs.xfce.org/panel-plugins/xfce4-xkb-plugin"
11 license=('custom')
12 groups=('xfce4-goodies')
13 depends=('xfce4-panel' 'libxklavier' 'librsvg' 'libwnck3' 'libnotify')
14 makedepends=('intltool')
15 optdepends=('xfce4-notifyd: show notifications on layout change')
16 install=$pkgname.install
17 source=(https://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
18 sha256sums=('f0bfe97875ef1ca0a3b6a6fac312663c9cada151cf1ac96071393d320cd04987')
20 build() {
21   cd "$srcdir/$pkgname-$pkgver"
23   ./configure \
24     --prefix=/usr \
25     --sysconfdir=/etc \
26     --libexecdir=/usr/lib \
27     --localstatedir=/var \
28     --disable-static \
29     --disable-debug
30   make
33 package() {
34   cd "$srcdir/$pkgname-$pkgver"
35   make DESTDIR="$pkgdir" install
36   install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
39 # vim:set ts=2 sw=2 et: