1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
4 # Contributor: William Rea <sillywilly@gmail.com>
9 pkgdesc="A toolkit for creating fast, portable, compelling dynamic UIs"
10 url="https://blogs.gnome.org/clutter/"
13 depends=(gtk3 cogl libinput)
14 makedepends=(gobject-introspection gtk-doc git)
15 _commit=fd85623d34a54b3f5607011086cf19cb2c756a6a # tags/1.26.4^0
16 source=("git+https://gitlab.gnome.org/GNOME/clutter.git#commit=$_commit")
21 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 NOCONFIGURE=1 ./autogen.sh
31 ./configure --prefix=/usr \
32 --enable-introspection \
33 --enable-egl-backend \
34 --enable-gdk-backend \
35 --enable-wayland-backend \
36 --enable-x11-backend \
37 --enable-evdev-input \
38 --enable-wayland-compositor \
41 # https://bugzilla.gnome.org/show_bug.cgi?id=655517
42 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
48 depends+=(libcogl{,-pango,-path}.so)
49 provides+=(libclutter-1.0.so)
52 make DESTDIR="$pkgdir" install