archrelease: copy trunk to extra-x86_64
[arch-packages.git] / clutter / trunk / PKGBUILD
blob38e6fc1da194d7a2f021efedc7695cf44424669d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
4 # Contributor: William Rea <sillywilly@gmail.com>
6 pkgname=clutter
7 pkgver=1.26.4
8 pkgrel=2
9 pkgdesc="A toolkit for creating fast, portable, compelling dynamic UIs"
10 url="https://blogs.gnome.org/clutter/"
11 arch=(x86_64)
12 license=(LGPL)
13 depends=(gtk3 cogl libinput)
14 makedepends=(gobject-introspection gtk-doc git)
15 _commit=fd85623d34a54b3f5607011086cf19cb2c756a6a  # tags/1.26.4^0
16 source=("git+https://gitlab.gnome.org/GNOME/clutter.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
26   NOCONFIGURE=1 ./autogen.sh
29 build() {
30   cd $pkgname
31   ./configure --prefix=/usr \
32     --enable-introspection \
33     --enable-egl-backend \
34     --enable-gdk-backend \
35     --enable-wayland-backend \
36     --enable-x11-backend \
37     --enable-evdev-input \
38     --enable-wayland-compositor \
39     --enable-gtk-doc
41   # https://bugzilla.gnome.org/show_bug.cgi?id=655517
42   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
44   make
47 package() {
48   depends+=(libcogl{,-pango,-path}.so)
49   provides+=(libclutter-1.0.so)
51   cd "$pkgname"
52   make DESTDIR="$pkgdir" install
55 # vim:set sw=2 et: